Closed Bug 1672164 Opened 1 year ago Closed 1 year ago

No search engines (address bar, preferences) after update to Firefox 82 with Linux Mint builds

Categories

(Firefox :: Search, defect)

Firefox 82
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: uri.neri, Unassigned)

References

Details

Attachments

(5 files)

Attached image NoSearchE.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:82.0) Gecko/20100101 Firefox/82.0

Steps to reproduce:

Sudden loss of search engines in search bar and address bar.
In preferences->Search: the list in the box is empty and restore to default doesn't work. Following the links to add custom search engines, and trying to add any, also doesn't work.
When pressing the three dots " * * * " in the side of the address panel - no such option to add as search engine.

Component: Untriaged → Search
Duplicate of this bug: 1672166

Thank you for the report. Could you provide more information about the issue by following these steps, please?

  1. Launch Firefox.
  2. Directly after the launch, press the Alt key.
  3. In the Tools menu, open Web Developer > Browser Console.
  4. On the top, switch the buttons so only "Errors" is active.
  5. If error messages are shown, please copy and paste them here.
    Thank you in advance.
Flags: needinfo?(uri.neri)

@zumrikushi

Since you filed a similar bug, can you provide the same info as comment 2, and details on your operating system?

Flags: needinfo?(zumrikushi)
Summary: No search engines → No search engines (address bar, preferences) after update to Firefox 82
Has Regression Range: --- → no
Has STR: --- → no

As requested.

Flags: needinfo?(uri.neri)

@Se(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #2)

Thank you for the report. Could you provide more information about the issue by following these steps, please?

  1. Launch Firefox.
  2. Directly after the launch, press the Alt key.
  3. In the Tools menu, open Web Developer > Browser Console.
  4. On the top, switch the buttons so only "Errors" is active.
  5. If error messages are shown, please copy and paste them here.
    Thank you in advance.

See new attachment (the txt file)

Also, checked Home Screen after reading @zumrikushi bug, it's blank here as well.

Did you install firefox from mozilla.org or the mint repositories? Can you attach the contents of about:support?

Flags: needinfo?(uri.neri)

(In reply to Julien Cristau [:jcristau] from comment #7)

Did you install firefox from mozilla.org or the mint repositories? Can you attach the contents of about:support?

The instance with the bug (the one the errors are from) I installed from the mint repositories.
I'm adding as attachment the "copy-raw-data-to-clipboard" paste.

Flags: needinfo?(uri.neri)

Sorry to request so many additional information, could you please go to about:config and enable browser.search.log , followed by opening the browser console (Ctrl+J) with a restat (Ctrl+Alt+R), then attach here please the log from the browser console.

Flags: needinfo?(uri.neri)

(In reply to Adrian Florinescu [:aflorinescu] from comment #10)

Sorry to request so many additional information, could you please go to about:config and enable browser.search.log , followed by opening the browser console (Ctrl+J) with a restat (Ctrl+Alt+R), then attach here please the log from the browser console.

Just to be sure; unlike in comment 2 step 4. , where only errors where toggled on, you want same but with only "log" toggled on?

Flags: needinfo?(uri.neri)

(In reply to Adrian Florinescu [:aflorinescu] from comment #10)

Sorry to request so many additional information, could you please go to about:config and enable browser.search.log , followed by opening the browser console (Ctrl+J) with a restat (Ctrl+Alt+R), then attach here please the log from the browser console.

If so, pasting here:
1603202488200 addons.xpi WARN Exception running bootstrap method startup on twitter@search.mozilla.org: Error: Error while loading 'jar:file:///usr/lib/firefox/browser/omni.ja!/chrome/browser/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND)(resource://gre/modules/Extension.jsm:600:20) JS Stack trace: readJSON/</<@Extension.jsm:600:20
onStopRequest@NetUtil.jsm:128:18

(In reply to Yuriman121 from comment #11)

(In reply to Adrian Florinescu [:aflorinescu] from comment #10)

Sorry to request so many additional information, could you please go to about:config and enable browser.search.log , followed by opening the browser console (Ctrl+J) with a restat (Ctrl+Alt+R), then attach here please the log from the browser console.

Just to be sure; unlike in comment 2 step 4. , where only errors where toggled on, you want same but with only "log" toggled on?

Let me clarify the request (slightly different from thee comment 2 request):

  1. In a new tab type about:config, accept the warning.
  2. Search for browser.search.log preference and set it to true.
  3. Enable the defaults: errors, warnings, log, info, debug in the browser console type.
  4. Then yes, the exported console output after a restart.
Flags: needinfo?(uri.neri)
Attached file BrowserConsole2
Attached file RequestedInfo4

Adding attachment now (btw, the paste-into-attachment thing notes it fails to upload because null...)

Flags: needinfo?(uri.neri)

Thank you for the information. From the attachment in comment 4:

uncaught exception: undefined
Uncaught (in promise) TypeError: MINT_LOG.warning is not a function

MINT_LOG is custom code added to the unofficial build used. The bug reports also seem to be only about Linux Mint.

This needs changes by the Mint build maintainer. Who is this, and are they on bugzilla.mozilla.org?

Summary: No search engines (address bar, preferences) after update to Firefox 82 → No search engines (address bar, preferences) after update to Firefox 82 with Linux Mint builds

So looking into this, as a first guess it looks like the distro is trying to patch the way we determine the users region and that code is throwing which is causing the SearchService to fail

For people that are having the problem, it looks like it may be fixed if users set "mint.use-system-region" to false

(In reply to Dale Harvey (:daleharvey) from comment #19)

For people that are having the problem, it looks like it may be fixed if users set "mint.use-system-region" to false

Confirmed! Thanks Dale!

Closing as invalid as the breakage seems caused by Linux Mint patches.

Status: UNCONFIRMED → RESOLVED
Has Regression Range: no → ---
Has STR: no → ---
Closed: 1 year ago
Flags: needinfo?(zumrikushi)
Resolution: --- → INVALID
Duplicate of this bug: 1672313
Duplicate of this bug: 1672200
You need to log in before you can comment on or make changes to this bug.