Closed Bug 1672434 Opened 3 months ago Closed 10 days ago

the first item in the Download list cannot be clicked sometimes

Categories

(Firefox :: Untriaged, defect)

78 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: skeletonzombie17, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

[firefox-version: 78.3.0esr (64-bit) debian-gnu-linux]
Download some files.
Open the download list (Library/Downloads).

Actual results:

Sometimes the topmost? item cannot be clicked.
At least it does not become blue when clicked.
(I do no understand how it is even possible for a single item to behave differently from the rest in such a list.)
(This issue has been present across some more recent versions of firefox.)

Expected results:

All items in the Download list should always be equally clickable,
and interact equally in all such regards.

I could not reproduce this issue on Ubuntu 20.04 on Firefox 78.4.0 esr or in the latest Nightly 84.0a1.

Skeleton Zombie, are you experiencing this issue on all the file types or only on some? Could you provide some examples?

Also, please can you confirm whether you reproduce this issue using Firefox in safe mode or with a new profile?
http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Flags: needinfo?(skeletonzombie17)

This is really a seldom one.
I cannot actively reproduce this myself.
I have encountered it several times throughout the last years(?).
Unfortunately I do not remember whether the secondary click on the item worked to get the context menu,
or whether it was possible to delete the item individually.
At least it was possible to clear the whole list.

When I encounter it the next time I will look closer...

Flags: needinfo?(skeletonzombie17)

There is more spooky behaviour with that download list.
It sometimes randomly selects an item, without being clicked, and one that has long finished downloading.
The proper behaviour should be to auto-select only when an item has completed its task.
No other part of firefox (except the save-as file-chooser https://bugzilla.mozilla.org/show_bug.cgi?id=1672368 ),
shows such behaviour.

Skeleton Zombie, did you had the chance to see if the issue is reproducible if running Firefox in safe mode or in a clean profile (the culprit for the issue you are having can be an add-on or some settings customization)?
http://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
http://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Flags: needinfo?(skeletonzombie17)

I have created a new profile,
I will investigate when/if this happens again.

Though I have set some options and have installed a single add-on, the ad-blocker ublock-origin,
otherwise firefox / the internet would be unusable.

Since this occurs so seldomly, trying it in a test-only profile is not possible.

I will wait until this occurs again.

Flags: needinfo?(skeletonzombie17)

Considering comment 5, I'm going to set the status of this report to Resolved Worksforme. Skeleton Zombie, please feel free to reopen it if the issue is back and you can provide additional details that could help us reproduce it. Thanks!

Status: UNCONFIRMED → RESOLVED
Closed: 10 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.