If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[RFE] Context-menu appears on click instead of release

NEW
Unassigned

Status

()

Core
XUL
--
enhancement
15 years ago
8 years ago

People

(Reporter: Sybren Stuvel, Unassigned)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
The context menu in the browser appears on the right-click on all non-windows
platforms/OSses I know.

Expected behaviour: the context menu appears on releasing the right mouse button.

This would really help the gestures project at http://optimoz.mozdev.org/
because these gestures are hardly usable now on any other platform than Windows.
Setting the LMB to the gestures button makes it hard to select text without
making a gesture. The MMB causes selected text to be pasted, which is also very
inconvenient if you only want to move one tab to the left/right (for instance).
Using the RMB for gestures interferes heavily with the context menu.

One of the beauties of Mozilla is that it behaves the same no matter what OS
you're using. This is one of the small details where things are different, and
it really matters in this case.
In the few linux apps I tried, the conext menu opens on mousedown. Mozilla
should be consistent with the rest of the platform.

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 89308 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
Oh wait, bug 89308 was about fixing that bug on Windows. You really want to move
that *bug* to all other platforms ? That is exactly the opposite. I'll reopen
this one.

And I'm still against, BTW. Opening a context menu should take one click, not 2.
If this creates problems with gestures, then the problem has to be fixed.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

15 years ago
I agree that this should be fixed in the cleanest way possible. Another approach
is a way to:

1) prevent the context menu from popping up
2) make the context menu pop up from any code

This way, the gestures module can prevent the context menu from popping up until
it's clear that you're not making a gesture. After that, it can still show you
the context menu. That would make the context menu appear with only a single
click of the RMB, and still allow nice gestures!

Comment 5

15 years ago
The menu is drawn on MouseDown for a reason. It exhibits the same behavior as
the toolbar menus. 

1. Right-click to bring up the context menu, but don't release the mouse button. 
2. Drag the pointer to an active selection. 
3. Release the button. 

This is actually more efficient, as you can select a menu option with two events
instead of four. (MouseDown and MouseUp instead of MouseDown+MouseUp
MouseDown+MouseUp)
(Reporter)

Comment 6

15 years ago
To start: that's very useful, and I use it too. No argue there.

It would be nice, though, to allow certain addons to alter this behaviour in
favour of additional functionality. Someone who simply uses mozilla should get
the desired behavior as you described. Someone installing an addon should get
the behaviour that the addon provides. In order to do this, there should be a
way for addons to influence the behavior of the context menu.

It won't interfere with the regular operation of Mozilla, and it gives more
power to the addons that which to use this. Seems like a good solution to me.
-> xp toolkit
Assignee: asa → hyatt
Component: Browser-General → XP Toolkit/Widgets: Menus
QA Contact: asa → shrir

Comment 8

15 years ago
Confirming RFE to "make it a pref", although that's not to say that the 
module owner will necessarily accept this. We've already been through this
more than once...
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Context-menu appears on click instead of release → [RFE] Context-menu appears on click instead of release
Target Milestone: --- → Future

Comment 9

15 years ago
*** Bug 190603 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
*** Bug 203522 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 11

14 years ago
The ability to properly use mouse gestures with the right mouse button is at
least working on Firefox. As far as I (the reporter of this bug) am concerned,
it can be closed.

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets

Updated

8 years ago
Assignee: hyatt → nobody
You need to log in before you can comment on or make changes to this bug.