smtp with multiple accounts on free mailer

RESOLVED DUPLICATE of bug 158099

Status

SeaMonkey
MailNews: Account Configuration
RESOLVED DUPLICATE of bug 158099
16 years ago
9 years ago

People

(Reporter: schlupp, Assigned: racham)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I have multiple accounts by one freemailer (gmx) and multiple mail-account in
mozilla. also I have multiple smtp accounts.

- in advanced outgoing server settings I have the same account name for all
(like "mail.gmx.de:25"). I suggest an alias for every account 

- when I compose a new mail and I select an mail account ("from" choicebox) so I
get an error popup "an error occurred while sending mail. the mail server
responded: {xxx} sender address does not belong to logged in user. ...." mozilla
should use the correct outgouing mail server settings for selected  account.

Comment 1

14 years ago
Just like in:
http://bugzilla.mozilla.org/show_bug.cgi?id=119609
http://bugzilla.mozilla.org/show_bug.cgi?id=151774
I cannot understand why it wasn't done right at first place, give the ability to
set an smtp server+username+password under the account settings instead of the
global smtp settings.

Comment 2

14 years ago
Reporter: Is this still a problem with a current Mozilla build? I also use GMX
and multiple accounts and it chooses the right outgoing server for a different
From (note: you have to use different outgoing server accounts, since GMX
requires authentification to fit the From from the account).
Product: Browser → Seamonkey
(In reply to comment #0)
> I have multiple accounts by one freemailer (gmx) and multiple mail-account in
> mozilla. also I have multiple smtp accounts.
> 
> - in advanced outgoing server settings I have the same account name for all
> (like "mail.gmx.de:25"). I suggest an alias for every account 

This is DUP of Bug 158099.

> when I compose a new mail and I select an mail account ("from" choicebox)
> so I get an error popup "an error occurred while sending mail.
> the mail server responded: {xxx} sender address does not belong to logged
> in user. ...."
> mozilla should use the correct outgouing mail server settings for selected 
account.

See next FAQ at Knoelwdge Base of MozillaZine.
http://kb.mozillazine.org/index.phtml?title=Thunderbird_:_FAQs_:_Multiple_SMTP_Servers
I think this is one of best descrition for "multiple SMTP use" currently available. 
Choose "correct SMTP" or "Always use default SMTP" for the account(or identitiy).
It is not impossible, although it is difficult due to Bug 158099, all SMTPs have
same label, and due to Bug 202045, order of SMTPs changes from time to time :-)
Workaround can be choosing "Always use deafult SMTP server".

Anyway, closing as DUP of Bug 158099.


*** This bug has been marked as a duplicate of 158099 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.