Closed Bug 1673804 Opened 11 months ago Closed 10 months ago

Moving top sites - moves to the the position +x (where x = sponsored positions) and generates new topsites placeeholders

Categories

(Firefox :: Top Sites, defect, P2)

Firefox 83
defect

Tracking

()

RESOLVED DUPLICATE of bug 1673429
Tracking Status
firefox-esr78 --- unaffected
firefox81 --- unaffected
firefox82 --- disabled
firefox83 --- fixed
firefox84 --- fixed

People

(Reporter: aflorinescu, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: regression)

[Sugested Severity:]

S2

[Description:]

There are cases when moving topsites around, causes the move to be made to a position incremented by the number of shown sponsored topsites(?). Also, doing it a while, it would cause bug 1673429 and additionally to create new topsites placeholders(>32+)

[Environment:]

Windows 10
83.0b5

[Preconditions:]

Position 1 and Position 2 have sponsored top sites.
Position 32 has sponsored top site.

[Steps:]
  1. Download and install RO localized Firefox.
  2. Create an user.js and set: browser.topsites.useRemoteSetting = true and browser.search.region to "RO", connecting to the staging main-preview.
  3. Start the browser with the predefined profile.
  4. Open a new about:preferences#home and set topsites to be shown on 4 rows.
  5. Open a new tab.
  6. Observe the topsites section.
  7. Drag and drop position 32 sponsored top site to position random position.
  8. Move a normal topsite to another position.
  9. Redo 7. or 8. multiple times.
[Actual Result:]
  1. Top sites are listed correctly: positions 1,2,32 have sponsored topsites
    7/8. Given the preconditions, you will get the top site moved to position +2
  2. Weird things start happening: bug 1673429, new topsites placeholders (check video_recording)
[Expected Result:]

Topsites get moved to the chosen position.

[Note:]

Please note that there is a trigger for the reported behavior, it's intermittent and not always reproducible.

Version: Firefox 84 → Firefox 83
Severity: -- → S2
Depends on: 1673429
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1673429
You need to log in before you can comment on or make changes to this bug.