Closed Bug 1673882 Opened 2 years ago Closed 2 years ago

Highlighting from the side panel does not work anymore

Categories

(DevTools :: Accessibility Tools, defect, P2)

defect

Tracking

(firefox-esr78 unaffected, firefox82 unaffected, firefox83 unaffected, firefox84 fixed)

RESOLVED FIXED
84 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox82 --- unaffected
firefox83 --- unaffected
firefox84 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Steps to reproduce

  1. Open the toolbox on this page
  2. Select the accessibility panel
  3. In the main view, select the document node
  4. Hover the DOMNode item crosshair icon in the side panel

Expected results

The element should be highlighted on the page

Actual results

It isn't.


I can see the following error in the terminal:

JavaScript error: resource://devtools/client/accessibility/components/Accessible.js, line 236: TypeError: can't access property "unhighlight", highlighterFront is undefined

Coming from https://searchfox.org/mozilla-central/rev/c409dd9235c133ab41eba635f906aa16e050c197/devtools/client/accessibility/components/Accessible.js#226-227

I think there was a recent change in highlighting for console and debugger, so maybe we missed some work here (and I guess we don't have a test covering this functionality)

Razvan, I guess this could have been regressed by Bug 1623667, do you confirm?

I'm going to try to fix this and add a test.

Flags: needinfo?(rcaliman)
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED

I can confirm that the highlighterFront property was removed from the NodeFront in Bug 1623667 (see https://hg.mozilla.org/integration/autoland/diff/c2fafe54a4cb4e8104084fccd40b8fd2b29c20ac/devtools/client/fronts/node.js)

Flags: needinfo?(rcaliman)
Regressed by: 1623667
Has Regression Range: --- → yes

The panel was using the highlighterFront property of the nodeFront, but it was
removed in Bug 1623667, and as a result, highlighting was broken.
To be consistent with the other panels having such capabilities (console, debugger, …),
we now use the toolbox getHighlighter function.

This wasn't caught because there wasn't any test covering this behavior; this patch
adds one, that was failing without the fix in Accessible.

@Nicolas, Thanks for finding and fixing this on your own initiative!
Indeed, this instance of highlighterFront wasn't addressed in Bug 1623667.
There wasn't a test (thanks for adding one!) but I guess my searchfox queries missed it too.

Thank you for taking swift action!

Set release status flags based on info from the regressing bug 1623667

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/532dcdd149e5
[devtools] Fix DOMNode icon in a11y panel sidebar. r=yzen.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch
You need to log in before you can comment on or make changes to this bug.