Crash when tabbing (Ctrl-Tab/F6/Ctrl-F6) into hidden IFRAMES

VERIFIED DUPLICATE of bug 146255

Status

()

Core
Event Handling
--
critical
VERIFIED DUPLICATE of bug 146255
16 years ago
15 years ago

People

(Reporter: Malcolm Rowe, Assigned: joki (gone))

Tracking

({crash, testcase})

Trunk
x86
Windows 2000
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

In the testcase (to follow), pressing Ctrl-Tab, F6, or Ctrl-F6 will crash the
browser.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

16 years ago
Created attachment 98350 [details]
Minimal testcase
(Reporter)

Comment 2

16 years ago
Talkback IDs:
TB10592643E
TB10592204G
TB10591888H
TB10591866Y


Updated

16 years ago
Keywords: crash, stackwanted
Whiteboard: [has talkback ID] TB10592643E

Comment 3

16 years ago
confirming using build 20020908 on Win2k (trunk).
Keywords: testcase
nsEventStateManager::IsIFrameDoc
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 4824]
nsEventStateManager::ShiftFocusByDoc
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 5076]
nsEventStateManager::PostHandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 1905]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6129]
PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6031]
nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2052]
nsView::HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 306]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1909]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1038]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1055]
nsWindow::DispatchKeyEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 2886]
nsWindow::OnKeyDown
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 2975]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3800]
0x18a16457 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: stackwanted
Whiteboard: [has talkback ID] TB10592643E

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 146255 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
By the way, nice testcase!  Made this real simple to track down.  Patch coming
up on bug 146255 in a few mins.

Updated

15 years ago
QA Contact: rakeshmishra → trix

Comment 7

15 years ago
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.