Tab gets associated with incorrect URL. (Loading a tab results in loading a window under a different tab.)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: ishikawa, Assigned: jag-mozilla)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
It is rather difficult to describe what has happened.
But let me try.

Basically, when I try to load an URL for one page
under a tab shows nothing in the window shown when that tab is selected,
BUT it turns out that the image is loaded into a different window
under a DIFFERENT tab.

That is the association between the URLs and TABs got
mixed up!

This has happened when I tried to load several pages by
 - firstly, searching URLs using google.
 and then 
LOOP:
 - trying to load interesting URLs using open URL under a different tab.
 - some pages were so slow loading and so I canceled it by
   hitting stop button.
 - I occasionally removed tabs when there are too many tabs.
 - repeat the above Loop.
ne
Then I realize that one page under a tab never shows its contents.
But the message at the lower-left corner of the mozilla window
says Loading and eventually "Document: Done." 
But nothig is shown. A blank page is shown.

*BUT* when I opened the right tab (i.e., the tab that is immediately
to the right of the tab in question) I see
the contents of the URL which I have tried to load and saw nothing of
the contents previously.
BUT the right tab has different URL associated with it and so
this is wrong!
(The tab name is different one.)

I confirmed that the right tab
is indeed associated with different URL by trying to reload under that
tab: it would try to load the original URL associated with that tab and
not the URL that comes from the left tab.

I suspect that there is a race somewhere in the handling of
 - tab and its url association and
   handling of cancellation of the loading of a page under a tab
   by user's hitting stop button.

It is easy to imagine such a bug can creep in.

My guess is that the internal data structure for the tab (the left one)
somehow  picked up the window area for the right tab
as its painting area when the race condition
tanbled some pointers.

This bug may be hard to believe, and nothing like this has happened
in the 9 months I have used Mozilla beta so far.
I was surprised myself.

I have uploaded two PNG figures to show the symptoms described above.
(Otherwise, people may not understand the description above.)

(1)
http://www.yk.rim.or.jp/~ishikawa/toms.png

(2)
http://www.yk.rim.or.jp/~ishikawa/sud.png

The fist picture shows the screen when a tab for 
a certain www.tomshardware.com URL is selected. It shows
the blank window and "Done." message.
The tab is the second rightmost one.
This is where I tried to load a page and saw nothing.

The second picture shows the screen when a tab for
a certain www.sudhian.com was chosen. 
The rightmost tab is the one.
(The picture is rather large, sorry about this. you may need
to scroll to the right to make sure you see the correct tab.)

Note the name of the tab.
*BUT* the contents of the window shown is the one for the
www.tomshardware.com  site!!! (which was just loaded using
the second right-most tab.)

Well, race condititions in handling stopped/cancelled loading
at the inappropriate time can certainly result in interesting
bug, can't it?
I was so puzzled about what has happened and it took me
quite a while to what was going on. (I tried to load tomshardware.com
many times to no avail [ not seeing the picture. ] and
then I realize that the right tab showed desired contents and
initially I thought someone at the URL was stealing the web contents from
tomshardware.com site and got quite disturbed. But it turned out to be mozilla
bug, I think.
tabbed browser.
Assignee: asa → jaggernaut
Component: Browser-General → Tabbed Browser
QA Contact: asa → sairuh

Comment 2

16 years ago
chiaki, you selected Mac System 8.0 when you filed this bug. Are you, in fact, using Mac OS 8.0? 
If so, Mozilla doesn't support Mac OS versions older than 8.5.
(Reporter)

Comment 3

16 years ago
After greg's post, I realized that
I didn't set the system info correctly.

I am using
  mozilla 1.1
 on linux PC (x86). Debian GNU/Linux kernel 2.4.19.

Can I simply change the OS/platform setting by 
submitting this? (Well, I am trying ...)
OS: Mac System 8.0 → Linux
Hardware: Macintosh → PC
QA Contact: sairuh → pmac

Comment 4

16 years ago
Confirming this with

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030116

The way to reproduce this for me, is to start loading multiple slow loading
URL-s (maybe disconnect network to facilitate name resolution lookup?) at the
same time (all should show "Loading ..."), than when one starts to arrive click
on the tab, than click on a different tab and you should see the same URL loaded
into different tabs, which is incorrect.

Comment 5

15 years ago
Reporter can you reproduce this bug with a newer build (1.4 final)?
If not, then please close this bug as worksforme. Thanks.

Comment 6

15 years ago
unable to reproduce with latest linux builds on fedora core 1.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.