Can't input Chinese in all 1.1 releases

VERIFIED DUPLICATE of bug 167003

Status

()

Core
Internationalization
VERIFIED DUPLICATE of bug 167003
16 years ago
16 years ago

People

(Reporter: Eric Yuan Zhao, Assigned: Roy Yokoyama)

Tracking

({intl})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a) Gecko/20020908
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2a) Gecko/20020908

This happens in Windows 2000/XP.  Mozilla 1.1 can display Chinese in web pages
properly.  But if you try to input Chinese in forms, emails, or the address bar,
it displays question marks.  This happens in both the English and the Chinese
versions of the browser.  I saw a very old bug about the same problem last dated
January 2002.  But there's no such a problem in Mozilla 1.0.  So, I file it as a
new bug.



Reproducible: Always

Steps to Reproduce:
1. Open Navigator or the email client.
2. Try inputting Chinese in any place where applicable, eg. the address bar, the
body of a new email, or a field of a form.  You can use any kind of Chinese
input tool.


Actual Results:  
The Chinese characters you've input appear as question marks.

Expected Results:  
The Chinese characters should be displayed properly.

Comment 1

16 years ago
==> Intl
Assignee: asa → yokoyama
Component: Browser-General → Internationalization
QA Contact: asa → ruixu

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 167003 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
verified as a dup.
Status: RESOLVED → VERIFIED
Keywords: intl
You need to log in before you can comment on or make changes to this bug.