Closed Bug 1674132 Opened 2 years ago Closed 9 months ago

Thunderbird Crash in [@ OOM | small] with language pack installed

Categories

(Thunderbird :: General, defect)

Thunderbird 82
x86_64
Windows 10
defect

Tracking

(thunderbird_esr91+ affected)

RESOLVED DUPLICATE of bug 1728744
Tracking Status
thunderbird_esr91 + affected

People

(Reporter: richard.leger, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, intl)

Crash Data

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1649023 +++
This bug is for crash report bp-fd615056-10c2-4297-a3ed-9b8400201029

Just encountered crash in TB 82.0b2 (64-bit)...

Attached image memory-managed-auto.png

FYI, memory is managed automatically by Windows 10 Pro 64bits 2004 on my machine...
I mention it because that something that was asked in the cloned bug this bug is coming from...

I doubt your crash is related to the component from which you cloned the bug. I'd say a high probability related to your many other crashes https://mzl.la/3kFgr2Q

(In reply to Richard Leger from comment #1)

Created attachment 9184526 [details]
memory-managed-auto.png

FYI, memory is managed automatically by Windows 10 Pro 64bits 2004 on my machine...
I mention it because that something that was asked in the cloned bug this bug is coming from...

Because manually managing memory in that case (which was a firefox crash) artificially limits memory size.

Component: Widget: Win32 → General
No longer depends on: 1649023
Product: Core → Thunderbird
Summary: Crash in [@ OOM | small] → Thunderbird Crash in [@ OOM | small]
Version: Other Branch → Thunderbird 82

Coincidentally, in the last few days OOM | small crashes spiked significantly, roughly 50% on Monday Nov 2. (perhaps related to large version 78 uptake?)
https://crash-stats.mozilla.org/signature/?product=Thunderbird&signature=OOM%20%7C%20small&date=%3E%3D2020-10-27T05%3A04%3A00.000Z&date=%3C2020-11-03T05%3A04%3A00.000Z#graphs

(In reply to Richard Leger from comment #0)

+++ This bug was initially created as a clone of Bug #1649023 +++
This bug is for crash report bp-fd615056-10c2-4297-a3ed-9b8400201029 82.0b2 (64-bit)...

This crash suggests you may have many other recent crash reports. Do they all have the same crash signature?

And the question remains, are you seeing some new crash, something related to your previous crash reports, or something older/generic like

  • Bug 1256224 - Thunderbird Windows crashes in OOM | small, even though Thunderbird is NOT out of memory per crash data
  • Bug 1353702 - Crash in PtrToNodeMatchEntry (CompareCacheMatchEntry) and OOM | small during CC. memory corruption, or memory leak?
Flags: needinfo?(richard.leger)

(In reply to Wayne Mery (:wsmwk) from comment #3)

(In reply to Richard Leger from comment #0)

+++ This bug was initially created as a clone of Bug #1649023 +++
This bug is for crash report bp-fd615056-10c2-4297-a3ed-9b8400201029 82.0b2 (64-bit)...

This crash suggests you may have many other recent crash reports. Do they all have the same crash signature?

Here is the list of my recent crashes:

bp-fd615056-10c2-4297-a3ed-9b8400201029 29/10/2020, 14:32
bp-4c5ec036-9077-457d-82f2-784d60201029 29/10/2020, 13:28
bp-1374061c-b8c4-4086-8b81-8ff8d0201028 28/10/2020, 16:40
bp-a2e84fe4-26f2-44e0-9ad4-0a9140201028 28/10/2020, 15:56
bp-27bead4e-c6f4-441f-b547-a71de0200823 23/08/2020, 10:18
bp-f1592ec3-2ff5-4ff8-a9a9-dddfb0200823 23/08/2020, 09:57
bp-03320ecd-ea8b-4cff-bc1b-072920200727 27/07/2020, 23:01

Hope that help...

Flags: needinfo?(richard.leger)
See Also: → 1616581

(In reply to Richard Leger from comment #4)

Hope that help...

Yes, in the sense that we can correlate it to your other crash signatures. The October crash reports are all OOM | small.

So your crashes come in short bursts? (October was four, August was two)

Flags: needinfo?(richard.leger)

(In reply to Wayne Mery (:wsmwk) from comment #5)

(In reply to Richard Leger from comment #4)

Hope that help...

Yes, in the sense that we can correlate it to your other crash signatures. The October crash reports are all OOM | small.

So your crashes come in short bursts? (October was four, August was two)

Yes it seems...

Here are those for Nov/Dec...

bp-caeeeef2-d80c-4255-947e-6ebc50201229 29/12/2020, 18:49
bp-cdcd04b4-edc3-44e4-aea2-4dfc00201203 03/12/2020, 21:49
bp-236423df-3725-4125-bff0-0fee90201118 18/11/2020, 10:25
bp-65e35416-9b03-467d-84b9-4a9950201104 04/11/2020, 08:06

But they may not necessarily be related to this bug...

Flags: needinfo?(richard.leger)

(In reply to Richard Leger from comment #6)

...
Here are those for Nov/Dec...

bp-caeeeef2-d80c-4255-947e-6ebc50201229 nsGlobalWindowInner::InitDocumentDependentState bug 1645865
bp-cdcd04b4-edc3-44e4-aea2-4dfc00201203 NS_CycleCollectorSuspect3 bug 1517464
bp-236423df-3725-4125-bff0-0fee90201118 MOZ_Z_inflate_table bug 1294074
bp-65e35416-9b03-467d-84b9-4a9950201104 shutdownhang | UniqueStacks::GetOrAddFrameIndex. no bug reported

mostly covered in bug 1333031 comment 23 bug repeated above

See Also: → 1333031

https://support.mozilla.org/en-US/questions/1330034 reports a mix of OOM | small and OOM | large

See Also: → 1660696

crash report bp-6161fa63-9227-45a0-b501-bd50f0210606 this am, unattended. restart of TBird 90.0b1 failed with hard spin. Win 10 64,
Could not start task manager to see what was spinning. Had to hard boot.

(In reply to doug2 from comment #9)

crash report bp-6161fa63-9227-45a0-b501-bd50f0210606 this am, unattended. restart of TBird 90.0b1 failed with hard spin. Win 10 64,
Could not start task manager to see what was spinning. Had to hard boot.

Uptime of two weeks is quite a long time :)

Richard, what is your current crash situation with beta?

Flags: needinfo?(richard.leger)

(In reply to Wayne Mery (:wsmwk) from comment #11)

Richard, what is your current crash situation with beta?

Here are my recent crash reports... if that can be of help...
bp-8b82a62c-e754-48eb-87ec-358720210705 05/07/2021, 15:26
bp-12c71778-1dd5-4e08-afa1-bf9790210705 05/07/2021, 15:15
bp-e99b3592-f699-469c-b750-d9cde0210407 07/04/2021, 17:18
bp-0aacd473-7139-4539-93f3-7e5180210406 06/04/2021, 19:15

Up to today I was on 90.x version now just upgraded to TB 91.0b4 (64-bit)

Flags: needinfo?(richard.leger)

Thanks - none of these crashes is OOM | small

I suspect the key to sorting out most of your crashes will be from fixing imap threading, in the likes of bug 1175168.

Depends on: 1175168
See Also: → 1718963

FWIW, OOM | small is on the rise for version 91. I'd be surprised if you didn't have recent crashes with that signature.

I suspect the key to sorting out most of your crashes will be from fixing imap threading, in the likes of bug 1175168.

The fix for bug 1175168 came in 94.0b2 on 10/7. What are some of your crash IDs since then when using the newer version?

Flags: needinfo?(richard.leger)
See Also: → 1738460

Just got an end-user that keeps having Thunderbird 91.2.1 Crash Report [@ OOM | small ] when opening the Preferences tab... it seems like it freeze TB, "Not responding" appears... and then at some point it crashes... report below...

bp-a58d2d49-1ee2-4222-af22-730f30211101

I'll keep the need info for now... to attempt answering your question...

In my current case (Bug 1738460 Comment 0) removing en-GB language pack (as suggested here Bug 1738460 Comment 5) and dictionary from Thunderbird 91.2.1 seems to have possibly fixed the problem... awaiting further feedback from end-user to confirm for sure...

End-user also mentioned that opening pdf files in TB not always work... it usually works the first time... but the second time it crash TB... in the period mentioned by end-user I only see [OOM | small] reports but I haven't been able to reproduce the issue to check which report is exactly generated in that case... and end-user was not exactly sure of date/time, so could also be possibly Bug 1738460.

(In reply to Wayne Mery (:wsmwk) from comment #14)

FWIW, OOM | small is on the rise for version 91. I'd be surprised if you didn't have recent crashes with that signature.

I suspect the key to sorting out most of your crashes will be from fixing imap threading, in the likes of bug 1175168.

The fix for bug 1175168 came in 94.0b2 on 10/7. What are some of your crash IDs since then when using the newer version?

In beta I only had few crashes not related to this bug...
bp-153ff11b-1179-4151-8607-eeacc0211105 05/11/2021, 11:02
bp-4c49f26a-881c-4c63-b7bd-a2d0f0211104 04/11/2021, 15:11
bp-fadc5f63-4982-4620-8b18-544430210809 09/08/2021, 09:36

End-user confirmed that issue is not resolved. So removing the language pack seemed to be the solution. I also set TB to open Adobe Reader instead of TB Preview for PDF... as removing the language pack allowed me to do so in Preferences (without crashing TB).

Flags: needinfo?(richard.leger)

(In reply to Richard Leger from comment #17)

(In reply to Wayne Mery (:wsmwk) from comment #14)

FWIW, OOM | small is on the rise for version 91. I'd be surprised if you didn't have recent crashes with that signature.

I suspect the key to sorting out most of your crashes will be from fixing imap threading, in the likes of bug 1175168.

The fix for bug 1175168 came in 94.0b2 on 10/7. What are some of your crash IDs since then when using the newer version?

In beta I only had few crashes not related to this bug...
bp-153ff11b-1179-4151-8607-eeacc0211105 05/11/2021, 11:02
bp-4c49f26a-881c-4c63-b7bd-a2d0f0211104 04/11/2021, 15:11
bp-fadc5f63-4982-4620-8b18-544430210809 09/08/2021, 09:36

Of the three, only the first has a sharp rise for version 91 (specifically 91.2.1) is shutdownhang | mozilla::TaskController::GetRunnableForMTTask | mozilla::storage::Service::Observe

and continues in 91.3.0 bp-79a06717-59f3-4d10-928f-c10050211105
0 ntdll.dll NtWaitForAlertByThreadId
1 ntdll.dll RtlSleepConditionVariableSRW
2 KERNELBASE.dll SleepConditionVariableSRW
3 mozglue.dll mozilla::detail::ConditionVariableImpl::wait(mozilla::detail::MutexImpl&) mozglue/misc/ConditionVariable_windows.cpp:50
4 xul.dll mozilla::TaskController::GetRunnableForMTTask(bool) xpcom/threads/TaskController.cpp:544
5 xul.dll nsThread::ProcessNextEvent(bool, bool*) xpcom/threads/nsThread.cpp:1086
6 xul.dll NS_ProcessNextEvent(nsIThread*, bool) xpcom/threads/nsThreadUtils.cpp:466
7 xul.dll mozilla::storage::Service::Observe(nsISupports*, char const*, char16_t const*) storage/mozStorageService.cpp:688
8 xul.dll nsObserverList::NotifyObservers(nsISupports*, char const*, char16_t const*) xpcom/ds/nsObserverList.cpp:70
9 xul.dll nsObserverService::NotifyObservers(nsISupports*, char const*, char16_t const*) xpcom/ds/nsObserverService.cpp:291
10 xul.dll static mozilla::AppShutdown::AdvanceShutdownPhase(mozilla::ShutdownPhase, char16_t const*, nsCOMPtr<nsISupports> const&) xpcom/base/AppShutdown.cpp:381
11 xul.dll mozilla::ShutdownXPCOM(nsIServiceManager*) xpcom/build/XPCOMInit.cpp:624

But, as a percentage, very few crashes with that signature have a language pack installed.

However, perhaps many new shutdown crashes also have language packs installed. For example all of this signature from the past month have a langpack installed https://crash-stats.mozilla.org/signature/?release_channel=%21release&product=Thunderbird&signature=AsyncShutdownTimeout%20%7C%20profile-change-teardown%20%7C%20Extension%20shutdown%3A%20lookout%40s3_fix_version%2CExtension%20shutdown%3A%20%7Ba300a000-5e21-4ee0-a115-9ec8f4eaa92b%7D&date=%3E%3D2021-10-05T23%3A15%3A00.000Z&date=%3C2021-11-05T23%3A15%3A00.000Z


OOM | small is a different matter:

  1. the version 91 crash rate is 4-5 times higher than version 78 (over the same week of late October when the user population of was about equal)
  2. approximately half (statistically significant) of version 91.2.1 crashes have a language pack installed, for example bp-7d9f0702-704e-41ca-bed1-124920211029 (unlike some other signatures, I spot checked a few, and none of the crash reports have language pack installed)

I am very happy we now know what causing the sharp increase in OOM | small crashes. I was about to put in major effort to determine the cause, and now I don't need to. THANK YOU Richard.

So, we VERY much need the following fixed in Thunderbird 91 - Bug 1642415 - Memory leak and high CPU when opening prefs/options/settings or on startup, due to language packs matching build locales with older translations that lack some strings causing excessive locale loading

Depends on: 1642415
Keywords: intl
See Also: → 1728744
Summary: Thunderbird Crash in [@ OOM | small] → Thunderbird Crash in [@ OOM | small] with language pack installed
See Also: → 1739848
See Also: → 1738973
See Also: → 1735661
Blocks: tb91found
Severity: -- → S2
Depends on: 1728744
See Also: 1728744
Depends on: 1742991

Wayne, why do you think this bug depends on Bug 1742991 rather than Bug 1728744, wasn't it identified that the root cause was linked to language pack rather than imap/url?

Highly likely to be fixed by bug 1728744 for Thunderbird 91.4.0.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1728744

Just to confirm applying TB Dec 2021 updates and re-installing Dictionary en-GB and Language pack en-GB no more Not Responding issue or crash observed. So issue seems fixed. Thank you all.

You need to log in before you can comment on or make changes to this bug.