If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When drop down is set to a filter, clicking event selects wrong event in month view

RESOLVED FIXED

Status

Calendar
Sunbird Only
RESOLVED FIXED
15 years ago
11 years ago

People

(Reporter: Russell Levy, Assigned: Mike Potter)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a) Gecko/20020611
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a) Gecko/20020611

When clicking an event in month view from the non-default calendar, the event
clicked is not hilighted, but an event from a different calendar is. Double
clicking will pop up an edit box for the alternate calendar.

Reproducible: Always

Steps to Reproduce:
1. Make sure at least two calendars have a few events
2. Click an event in month view from any calendar but the default calendar
Actual Results:  
The wrong event is selected.

Expected Results:  
selected the event which was clicked.
(Assignee)

Comment 1

15 years ago
This is related to selection problems with the tree.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

15 years ago
The problem is that the function
calendarEventView.prototype.getCalendarEventAtRow returns the wrong value if
items are hidden.
Summary: clicking event in month view from the non-default calendar selects another event → When drop down is set to a filter, clicking event selects wrong event in month view
(Assignee)

Comment 3

15 years ago
This is fixed in cvs now.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 4

15 years ago
Default QA Contact for Calendar has changed.  If you wish to remain the QA
contact for this bug, feel free to change it back.
QA Contact: colint → brantgurganus2001
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.