only default calendar listed calendar file drop box in add new event

RESOLVED WORKSFORME

Status

Calendar
Sunbird Only
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Russell Levy, Assigned: Mike Potter)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a) Gecko/20020611
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1a) Gecko/20020611

When adding a new event, the only calendar file listed is 'default', when there
are other local calendars in use. 
Problem only for new events, new tasks do not have the problem.

Reproducible: Always

Steps to Reproduce:
1. Go to File|New Event
Actual Results:  
A new event window popped up, but the calendar file drop down box only had one
entry--'Default'

Expected Results:  
I should have the option of all calendars.
(Reporter)

Comment 1

15 years ago
It seems the problem is with this line in calendarEventDialog.js:

         if( serverList[i].remote != true )
It's always evaluating to true except for the main calendar. This line doesn't
exist in calendarToDoDialog.js, that's why it pops them all up.

And the reason, it seems they evaluate to true is because in prefs.js, remote is
set to true for all calendars I added. So I guess the new bug should be, "local
calendars remote property set to true in prefs.js"
(Assignee)

Comment 2

15 years ago
*** Bug 167437 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

15 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 3

15 years ago
This is working fine for me now. Please reopen if you continue to see this problem.
You may have had one of the very early builds of the calendar.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 4

15 years ago
Default QA Contact for Calendar has changed.  If you wish to remain the QA
contact for this bug, feel free to change it back.
QA Contact: colint → brantgurganus2001
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.