Last Comment Bug 167483 - Conn: Dial Up Network (DUN) started with live LAN Internet connection preset
: Conn: Dial Up Network (DUN) started with live LAN Internet connection preset
Status: VERIFIED DUPLICATE of bug 167624
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: x86 Windows NT
: -- normal (vote)
: ---
Assigned To: general
: benc
: Patrick McManus [:mcmanus]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-09 05:42 PDT by Frank Helk
Modified: 2003-03-24 15:11 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Frank Helk 2002-09-09 05:42:24 PDT
Unter Win NT SP6a the DUN is launched even while a live LAN connection to the
internet is present. If not actually buried somewhere, the use of DUN should be
made optional.
Comment 1 Matthias Versen [:Matti] 2002-09-09 19:25:22 PDT
Build ID ?

-> Networking 
Comment 2 benc 2002-09-09 23:50:58 PDT
Steve: what additional information is needed here?
Comment 3 Frank Helk 2002-09-10 02:36:19 PDT
Build: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020826

Observation: It happens when a web site is very slow or down. The browser then
seems to assume that the connection is broken, even when the LAN connection is
still alive.

Suggested solution: Add a choice "Internet connection Type" with options "LAN"
and "Dial in" under Edit -> Prefrences -> Advanced -> System. "Dial in" should
have an checkbox for "Allow auto dialing".
Comment 4 Steve Meredith (gone) 2002-09-10 09:10:49 PDT

*** This bug has been marked as a duplicate of 167624 ***
Comment 5 benc 2002-09-11 07:10:10 PDT
Steve, is there a bug that covers adding the pref?
Comment 6 Steve Meredith (gone) 2002-09-11 08:51:23 PDT
The pref was added in bug 93002. It might be moved to a different file in bug
157246.
Comment 7 benc 2002-09-12 03:18:05 PDT
I mean something that is end-user accessible.

If it doesn't exist, I'll file one soon.
Comment 8 Steve Meredith (gone) 2002-09-12 08:47:24 PDT
That pref isn't surfaced in the pref UI. You are meant to turn the feature on
and off via the OS settings, like you do on other platforms.
Comment 9 benc 2002-09-21 01:35:25 PDT
Frank, please look at the duplicate bug for a solution. 
Comment 10 Frank Helk 2002-09-23 23:54:08 PDT
O.K. - I've fixed the behaviour via the OS settings, but it would be nice to be 
able to prevent autodial from within mozilla.
Comment 11 benc 2003-03-24 15:11:56 PST
VERIFIED/dupe.
Is there an RFE that asks for a pref UI control? I thought there was, but I
could not find it.

Note You need to log in before you can comment on or make changes to this bug.