Closed Bug 1674982 Opened 2 years ago Closed 2 years ago

[Wayland] Revert Bug 1668771 (frame callbacks timeout) due to OOM crashes

Categories

(Core :: Widget: Gtk, defect, P3)

defect

Tracking

()

RESOLVED FIXED
84 Branch
Tracking Status
firefox83 --- fixed
firefox84 --- fixed

People

(Reporter: stransky, Assigned: stransky)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

We need to revert Bug 1668771 (frame callbacks timeout) due to OOM crashes.

Wayland protocol does not include a mechanism how to inform compositor about deleted frame callbacks. We delete the callback only locally on client side and it remains active at server (compositor) side.

When large amount of callbacks is accumulated at server Firefox is closed due to OOM.

Wayland protocol does not include a mechanism how to inform compositor about deleted frame callbacks.
We delete a callback only locally on client side and it remains active at server (compositor) side.

When large amount of callbacks is accumulated at server Firefox is closed due to OOM
so we need to keep frame callback on local side untill is fired and don't create a new one.

Pushed by abutkovits@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3da7cf56aeb5
[Wayland] Revert frame callbacks timeout due to OOM crashes, r=jhorak
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch

Martin, it seems we want this patch uplifted to 83 beta, right?

Flags: needinfo?(stransky)

Yes, I'd like to uplift this one.
Thanks.

Flags: needinfo?(stransky)

Comment on attachment 9185413 [details]
Bug 1674982 [Wayland] Revert frame callbacks timeout due to OOM crashes, r?jhorak

Beta/Release Uplift Approval Request

  • User impact if declined: Firefox crashes when it's rendering web content on background, like youtube playback on background or so.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low risk - it only reverts a single patch which causes the failure.
  • String changes made/needed: none
Attachment #9185413 - Flags: approval-mozilla-beta?

Comment on attachment 9185413 [details]
Bug 1674982 [Wayland] Revert frame callbacks timeout due to OOM crashes, r?jhorak

Linux recent crash fix on Wayland, approved for beta 9, thanks.

Attachment #9185413 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.