Crash when clicking stop in toolbar before page finishes loading [@ js_FreeStack]

RESOLVED DUPLICATE of bug 193710

Status

--
critical
RESOLVED DUPLICATE of bug 193710
17 years ago
14 years ago

People

(Reporter: chi-ho.kwok, Assigned: asa)

Tracking

({crash, stackwanted})

Trunk
x86
Windows XP
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
Mozilla crashes when I click stop while loading www.ecs.com

I made the mistake to go www.ecs.com instead of www.ecs.com.tw when looking for
info, as soon as I see the title, I click stop and mozilla crashes! This
happened a few times already (first time was at least half a year ago). Instead
of stopping I got the netscape talkback thing. 

It can be reproduced every time, on both of my pc's, on different versions. 

One more strange thing is that my harddisk goes wild while loading the site (and
even more when I clicked stop).

Comment 1

17 years ago
Verified in build 2002090504 PC/Win98.
Went to URL, hit stop when TITLE came up.  Browser crashed, talkback ID TB10632091M.

MOZILLA caused an invalid page fault in
module JS3250.DLL at 0187:600ba0b7.
Registers:
EAX=00193c11 CS=0187 EIP=600ba0b7 EFLGS=00010206
EBX=01f48eec SS=018f ESP=0064ef8c EBP=0064ef90
ECX=03f57790 DS=018f ESI=0064f04c FS=3fd7
EDX=00000000 ES=018f EDI=80000000 GS=0000
Bytes at CS:EIP:
3b 02 73 04 89 02 eb 09 8b 42 04 89 81 78 01 00 
Stack dump:
03f55060 0064f090 6051dcef 03f57790 0064f04c 00000000 60e985aa 03eebe30 60e9f678
0064efbc 00000007 8000003f 006e006f 00720065 006f0072 00000072 

If I let the page fully load, no crash occurs.

Raised severity to critical, added kw crash.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Summary: crash when clicking stop in toolbar → Crash when clicking stop in toolbar before page finishes loading

Comment 2

17 years ago
can you use a Talkback enabled build, submit Talkback data when crashing and
post Talkback ID for this crash here ?
Once Talkback data has been submitted (after crashing), TB ID is available in
'mozilla/bin/components/talkback.exe'.
Keywords: stackwanted

Comment 3

17 years ago
Bill's stack from comment #1 (TB #10632091)
---------------------------
Product ID MozillaTrunk
Build ID 2002090504
Operating System Windows 98 4.10 build 67766446
URL visited http://www.ecs.com
User Comments Page was loading, hit stop before it finished. Browser then crashed.

Stack Trace
js_FreeStack [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 409]
nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp, line 188]
nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1183]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1854]
GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 766]
nsDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsDocument.cpp, line 3547]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2084]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2084]
nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp, line 2084]
nsHTMLScriptElement::ScriptAvailable
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLScriptElement.cpp,
line 363]
nsScriptLoadRequest::FireScriptAvailable
[c:/builds/seamonkey/mozilla/content/base/src/nsScriptLoader.cpp, line 112]
nsScriptLoader::FireScriptAvailable
[c:/builds/seamonkey/mozilla/content/base/src/nsScriptLoader.cpp, line 504]
nsScriptLoader::OnStreamComplete
[c:/builds/seamonkey/mozilla/content/base/src/nsScriptLoader.cpp, line 606]
nsStreamLoader::OnStopRequest
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsStreamLoader.cpp, line 163]
nsHttpChannel::OnStopRequest
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 2960]
nsOnStopRequestEvent::HandleEvent
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsRequestObserverProxy.cpp, line 213]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 644]
PL_ProcessPendingEvents [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c,
line 577]
_md_EventReceiverProc [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line
1309]
KERNEL32.DLL + 0x24407 (0xbff94407)
0x00648bf6 
Summary: Crash when clicking stop in toolbar before page finishes loading → Crash when clicking stop in toolbar before page finishes loading [@ js_FreeStack]

Comment 4

17 years ago
I don't know if it's related to this. But when I hit the stop button while a
page is loading, it tries to open my dial-up connection in the background
(although I am connected to a network). Since I didn't see it, it seemed that
Mozilla has locked up. Maybe on computers without a second connection to the
internet, Mozilla crashes at that point.
But no crash here (Win2K, Gecko/20020826)

Comment 5

16 years ago
Do you still crash using latest 1.2 build ?
http://ftp.mozilla.org/pub/mozilla/nightly/latest-1.2
(Reporter)

Comment 6

16 years ago
Just tested it with 1.2.1, caused crash in forth try on www.ecs.com.

Comment 7

16 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

TB16627846Q
TB16627849Z

Comment 8

16 years ago
Created attachment 114677 [details]
A simple testcase to reproduce the bug

I will attach a second file to make the testcase complete.

Comment 9

16 years ago
Created attachment 114678 [details]
An empty javascript

Comment 10

16 years ago
Created attachment 114679 [details]
Zipped testcase

Comment 11

16 years ago
It is easier to reproduce the bug locally.

1. Download the zipped testcase and unzip to a local directory
2. Open test.html locally
3. Hold down CTRL+R
4. Mozilla crashes consistently

This is probably a Javascript Engine bug. It could be related to bug 193710.

Comment 12

16 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030210

TB17265070X Bug 167499 with testcase
TB17265069Z Bug 167499 with testcase
TB17264899E Bug 167499
TB17264895Y Bug 167499
TB17264894G Bug 167499 still
TB17264888K Bug 167499 investigation
TB17264837E Bug 167499 with a local copy of www.ecs.com
TB17263633M Bug 167499 with a local copy of www.ecs.com
TB17263630E Bug 167499
TB17259549Y Bug 167499
TB17259106X Bug 167499
Yeah, this is a dup.

*** This bug has been marked as a duplicate of 193710 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
Crash Signature: [@ js_FreeStack]
You need to log in before you can comment on or make changes to this bug.