Closed Bug 1675415 Opened 11 months ago Closed 5 months ago

New mail notifications list older message rather than message that came in

Categories

(Thunderbird :: Mail Window Front End, defect, P2)

Tracking

(thunderbird_esr78 wontfix, thunderbird88 affected)

RESOLVED FIXED
89 Branch
Tracking Status
thunderbird_esr78 --- wontfix
thunderbird88 --- affected

People

(Reporter: yoachim, Assigned: rnons)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:81.0) Gecko/20100101 Firefox/81.0

Steps to reproduce:

I have numerous filters set for incoming mail. All the messages seem to get filtered properly, but system notifications are not correct.

Actual results:

I will often get a notification like "1 new message from Joe", when in fact the message from Joe is an older (filtered) message, and another (also filtered) message has actually arrived and triggered the notification.

Expected results:

I expect the notification of new messages to list the actual sender of the message that triggered the notification.

Whiteboard: DUPEME

Let's reuse this.
Bug 375717 fixed a bug, but not exactly how we should not notify more than once when one message comes in.
Atm (at least for the non-native notifications) we keep listing messages that are NEW.

How it should behave: once we notified about messages that came in, we should not show them in the notification again - you're already notified! Only show messages that you were not notified about.

Keeping track of which msgs were notified about already is tricky. I can't find the bug where this is discussed now, but my suggestion there was to keep track of the time (Date:, or last Received: if that is available) of the last message we notified about. Then only notify about messages newer than that. It's not 100% perfect but may be as good as it gets.

Assignee: nobody → remotenonsense
Status: UNCONFIRMED → NEW
Component: Untriaged → Mail Window Front End
Ever confirmed: true
Priority: -- → P2
Whiteboard: DUPEME
Status: NEW → ASSIGNED
Target Milestone: --- → 89 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/f46753fef395
Prevent showing old messages in newmailalert.xhtml. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Depends on: 375717
You need to log in before you can comment on or make changes to this bug.