In Mozilla 1.0 quitting the application causes my machine to freeze

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Ray and/or Tosca DeGennaro, Assigned: asa)

Tracking

({crash, stackwanted})

Trunk
PowerPC
Mac System 9.x
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       iCab/2.8.1 (Macintosh; I; PPC)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0.0) Gecko/20020529

I downloaded Netscape 7.0 on the day that it was avilalble.  The application froze while quitting.  I grabbed Mozilla the next day to see if the same thing happens and it does.

Reproducible: Always

Steps to Reproduce:
1. Start Mozilla
2. Use Mozilla (optional)
3. Quit Mozilla or select Shutdown from the Special meun in the Finder.

Actual Results:  
The computer froze, and I had to power cycle the machine.  I couldn't Cmd-Opt-Esc or Cmd-Ctrl-Power.

Expected Results:  
Quit nicely.

I also get an "illegal character" in the PRefs file warning.  I don't thinkl that they should be related.

Comment 1

16 years ago
Ray & Tosca, can you reproduce this problem using another Mozilla user profile?

Does TalkBack generate reports after these crashes? If so, please provide the ID of at least one 
such report.

If not, do you have TalkBack enabled? (If not, please enable it.)
Keywords: crash, stackwanted
(Reporter)

Comment 2

16 years ago
Ok, I started Mozilla by double clicking on the "Mozilla Profile Manager" icon in the Mozilla folder.  First tried to convert an existing profile, but clicking on the "Start Mozilla" button after converting the profile did nothing.  After progressing through the Alert boxes (Shouldn't these be Movable Modal?) I was returned to the Profile Manager Dialog box.

Next, I created a new profile and Mozilla froze on quit again.  I could not get TalkBack to pop-up.  Is there a way to force it? Cmd-Opt-Ctrl-Esc to drop into the debugger doesn't seem to work.

Finally, I tried it again, using the newly created profile from the start.  Same freeze on quit.

Here's more system details:

Power Mac 8500
168 MB RAM/VM at 256 MB
2, 1 & 1 GB harddrives
Internal Video & PCI Voodoo3
PCI Keyspan USB Card

Is there a more recent 1.0.x build I can try?

Comment 3

16 years ago
Ray and/or Tosca, yes; you can download 1.0.1 now from mozilla.org.
(Reporter)

Comment 4

16 years ago
Nope, pretty much the same crash with 1.0.1  Differences:  1)  I get a watch cursor while Mozilla is actually quitting, and then the machine freezes as soon a the cursor changes back to an arrow.  2)  I can actually use the power button to turn off the machine, with version 1.0, I had to pull the plug.

Comment 5

16 years ago
Ray and/or Tosca, if you disabled TalkBack at some point, you can re-enable it
by running the application and changing its' preferences. It's in the TalkBack
folder in the Mozilla folder.
(Reporter)

Comment 6

16 years ago
Ray here again, TalkBack has always been enabled.  It has just never popped-up for *this* problem.  Probably because I have to power cycle the machine to get control back.  I have Cmd-Opt-Ctrl-[Esc|Keyboard Power] (I can't remember which) and wound-up in the debugger, but never TalkBack.  That's why I was asking if there was a TalkBck "Hot Key" of some kind -- Some key sequence I could press that would hopefully generate a TalkBack report.  Would installing MacsBugs help?  I remember that it had a stack dump, but I can't rember the command.

Comment 7

16 years ago
Worksforme, Mozilla 1.3 alpha 2002121204, Windows 98.

Reporter, please download and install Mozilla 1.2.1 or later and try this
problem again. Does it still crash?

Please also test it with a fresh profile. You can create a new profile by
running Mozilla with this command:

mozilla -profilemanager

Comment 8

16 years ago
Ray n Tosca, your best bet is to update to Mozilla 1.2.1 with Talkback.

Mozilla CFM build is dead.
http://groups.google.com/groups?threadm=avkj4k%24ihs2%40ripley.netscape.com
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.