Closed Bug 1675697 Opened 4 years ago Closed 3 years ago

smooth scrolling on folder pane is choppy

Categories

(Thunderbird :: Folder and Message Lists, defect)

Unspecified
macOS
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1677380

People

(Reporter: starkjs, Unassigned)

Details

(Keywords: perf)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:82.0) Gecko/20100101 Firefox/82.0

Steps to reproduce:

Upgrade from Thunderbird 68 to 78
Scrolling on Folder pane is not smooth and choppy

Actual results:

When upgrading to 78.4.0 from 68.x I have found that the smooth scrolling on the folder pane is not working, it's very rough and choppy.
It works fine every where else on the email lists, in the message window and in all the setting pages.

I am running Thunderbird on MacOS 10.13.6
I then also upgraded Thunderbird on my work Mac, which is on MacOS 10.14.6
I am seeing the same issue there too.

Expected results:

I expect the scrolling in the Folder pane to be smooth as it was previously.

Component: Untriaged → Folder and Message Lists
OS: Unspecified → macOS

Tried disable hardware acceleration in the Thunderbird preferences?

(In reply to Magnus Melin [:mkmelin] from comment #1)

Tried disable hardware acceleration in the Thunderbird preferences?

If it's was application wide, then I would think it's relevant, but it is "only" the folder pane on the left that is not working, all other panes and settings scroll smoothly.

There seems to be no way to turn off hardware acceleration in Thunderbird preferences on MacOS
Do you have any information on where the page or setting is?

Additional diagnostic info.
I did a fresh install of 68.12.1 and created a new Profile, scrolling is all smooth in the folder pane
I did a fresh install of 78.0.1 and created a new Profile, scrolling is all rough and choppy in the folder pane
I did a fresh install of 78.4.1 and created a new Profile, scrolling is all rough and choppy in the folder pane

Open the Thunderbird preferences, and search for hardware acceleration. Change, restart and check the behaviour.

(In reply to Magnus Melin [:mkmelin] from comment #4)

Open the Thunderbird preferences, and search for hardware acceleration. Change, restart and check the behaviour.

Thanks for the reply, the only hardware acceleration is related to "Indexing" and the description is "Use hardware acceleration when available".
The doesn't seem to be related to any UI graphics. I have turned if off and re-tested and made no difference.

Is there a setting elsewhere for UI hardware acceleration? (which I doubt the issue is mind you)

I confirm that scrolling the folder pane in TB 78 is clumsy or choppy, even when hardware acceleration is disabled.
Running macOS 10.14.6.

Have recently upgrade macOS from 10.13 to 10.15, still have the rough and choppy scrolling with Thunderbird 78.5.1
Now I am on macOS 10.15, I upgraded Thunderbird from 78.5.1 to 78.6.0, still have the rough and choppy scrolling

another one for bug 1677380

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Keywords: perf
Resolution: --- → DUPLICATE
Summary: smooth scrolling on folder pane not working → smooth scrolling on folder pane is choppy
You need to log in before you can comment on or make changes to this bug.