fix CAB ui to have an AB picker for which AB to collect into, remove UI and code for "limit CAB size"

RESOLVED FIXED in mozilla1.2beta

Status

RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: sspitzer, Assigned: sspitzer)

Tracking

Trunk
mozilla1.2beta
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 5 obsolete attachments)

fix CAB ui to have an AB picker for which AB to collect into, remove UI and code
for "limit CAB size".

the picker can only show ABs that are writable (so no LDAP).

I think we should remove the code that does that altogether (from prefs UI,
default pref, and current CAB C++ code)

All this comes from mscott's document about how to fix the CAB.  See
http://rocknroll/users/mscott/publish/Documents/cab.html

Comment 1

16 years ago
Size Limit pref bug 158436.

Comment 3

16 years ago
Here's the document on mozilla.org that talks about the CAB changes we'd like to
make:

http://www.mozilla.org/mailnews/arch/cab.html
*** Bug 158436 has been marked as a duplicate of this bug. ***
patch coming.  I got the UI fixed, now just fixing the back end...
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2beta
Created attachment 98702 [details] [diff] [review]
UI works, BE doesn't compile yet.  I'll finish tomorrow...
Created attachment 98735 [details] [diff] [review]
testing now...
Attachment #98702 - Attachment is obsolete: true
Created attachment 98739 [details] [diff] [review]
add "New IM" button to ab toolbar.  im's single user, chat invites multiple
Attachment #98735 - Attachment is obsolete: true
Created attachment 98742 [details] [diff] [review]
updated patch
Attachment #98739 - Attachment is obsolete: true
Created attachment 98745 [details] [diff] [review]
patch, use Messenger::OpenURL() to launch the goim urls
Attachment #98742 - Attachment is obsolete: true
Created attachment 98748 [details] [diff] [review]
patch
Attachment #98745 - Attachment is obsolete: true

Comment 12

16 years ago
looks fine.

nit: in the two places this occurrs:
+  if (NS_FAILED(rv) || prefVal.IsEmpty())
+    rv = adCol->SetAbURI(kPersonalAddressbook);
+  else 
+    rv = adCol->SetAbURI(prefVal.get());
+

you could just use the ? operator here (up to you)
rv = adCol->SetAbUri((NS_FAILED(rv) || prefVal.IsEmpty()) ? kPersonalAddressBook
: prevVal.get())

Comment 13

16 years ago
Comment on attachment 98748 [details] [diff] [review]
patch

sr=bienvenu
Attachment #98748 - Flags: superreview+
I'll follow your suggestion before checking in, thanks.
fixed.

see bug 168115, which covers the "IM" button.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Updated

16 years ago
QA Contact: olgam → nbaca
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.