in Java applets text labels on controls are rendered incorrectly

RESOLVED INVALID

Status

()

Core
Internationalization
RESOLVED INVALID
15 years ago
3 months ago

People

(Reporter: Andrew Novikov, Assigned: Jungshik Shin)

Tracking

({intl})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; uk-UA; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

In GalaChat Java applet at http://chat.gala.net/ text labels on buttons and
other controls rendered incorrectly and are not readable.

Reproducible: Always

Steps to Reproduce:
NOTE: you should have cyryllic support and fonts installed correctly.
1. Go to http://chat.gala.net/
2. Enter username 'Mozilla' and password 'www.mozilla.org' (no quotes) or any
other username and password. 
3. Select Java version by clicking appropriate radiobutton (HTML chat is
selected by default).
4. Submit form.

Actual Results:  
In window bottom there are some buttons to send messages, ignore users, request
help etc. Text labels on buttons, drop-down lists etc are written in russian. In
all versions of Netscape and Mozilla those labels are unreadable.

Expected Results:  
Render text labels so that I could read it.

Updated

15 years ago
Keywords: intl
QA Contact: ruixu → ylong
(Reporter)

Comment 1

15 years ago
Created attachment 98494 [details]
That's how controls are displayed in Mozilla
(Reporter)

Comment 2

15 years ago
Created attachment 98496 [details]
That's how controls should be displayed (screenshot from IE6 on WinXP)
which JRE ?

Comment 4

15 years ago
Andrew Novikov:
Which OS language of your WinXP?
Could you please try to switch your WinXP locale to russian to see if they would
be displayed OK?

It might be related with bug 114078.
(Reporter)

Comment 5

15 years ago
I'm using JRE 1.3.1, OS: WindowsXP Corporate Edition English, locale is
already set to russian.

Comment 6

15 years ago
I failed to login...confirm by reporter's screen shot (under russian locale WinXP).
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 169302 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
I can see the same problem on Linux with BlackDown Java 1.4.1b

 There's simpler test case at MozillaPL.org site - it tests wheather you can
enter and display Polish characters. 

There's no problem with Windows and Polish locale. 
Even if you have Polish locale there are no Polish characters on Component Label
(when you enter the page with Linux it displays ??? instead of correct letters)
and you can enter and display them on TextField Component (below).

The test  case:
http://mozillapl.org/mozilla/czat/applet-test.html

We will try to improve it (add source, tell me what else is needed in a second)

Comment 9

15 years ago
cc xiaobin.lu@eng.sun.com
(Reporter)

Comment 10

15 years ago
The problem doesn't appear after installing Windows XP Service Pack 1 and
upgrading JRE to 1.4.0. Perhaps JRE 1.3 is the source of problem. I have no way
to test it on JRE 1.4 without WinXP SP1.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 11

15 years ago
Mark as verified per comment above.
Status: RESOLVED → VERIFIED

Comment 12

15 years ago
It still doesn't work,.. This problem affects all OS versions but:

 on Windows if your locale matches the one in the applet you're fine, if they
doesn't (say I with Polish locale will go to this Ukrainian test page) some
components (label) will be displayed incorectly characters replaced with ???.

on Linux the problem with label component doesn't really depend on your locale.
Doesn't matter if they match or they don't with the charset of the label in
applet - you will always get international characters replaced with ??? Whe have
tried to tweak fontproperties or fontproperties.pl file (to include proper
iso-8859-2 character set) but in almost every case this change coused Mozilla to
crash (or wasn't giving any effects at all - tested on few different
PC;s/distributions)

Summary of all tests can be found here:
http://mozillapl.org/mozilla/czat/applet-test.html
Please let me know if it's clear enough.

The OS version field has to be changed to All and the bug should be open again
unless you want me to file another bug.

Adding myself and our Java coordinator to the CC.

Comment 13

15 years ago
Adding Gabriel to CC list.

Comment 14

15 years ago
There is a bug talking about applet display garbled in different locale:
http://bugzilla.mozilla.org/show_bug.cgi?id=114078
Seems like it's the same windows problem in comment #12.

And for linux, I don't know if it's related with the available fonts in system.

I'm re-open this bug per comment #12.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 15

13 years ago
I think both roy and me are off mozilla for more than 2 years. If these bugs are
still here now, I think the real stauts is 'won't fix'. If you want to reopen
it, please find a new owner for it first. 
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago13 years ago
Resolution: --- → WONTFIX

Comment 16

13 years ago
Mass Reassign Please excuse the spam
Assignee: tetsuroy → nobody

Comment 17

13 years ago
Mass Re-opening Bugs Frank Tang Closed on Wensday March 02 for no reason, all
the spam is his fault feel free to tar and feather him
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 18

13 years ago
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW
QA Contact: amyy → i18n
The HTML <applet> element and related java functionality was removed from Gecko in Bug 1279218. Marking related bugs as invalid.
Status: NEW → RESOLVED
Last Resolved: 13 years ago3 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.