Toolbar button should show/hide all toolbars

VERIFIED WONTFIX

Status

Camino Graveyard
Toolbars & Menus
--
minor
VERIFIED WONTFIX
16 years ago
12 years ago

People

(Reporter: Jon Hall, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino1.5
PowerPC
Mac OS X

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020909
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020909

When the toolbar disclosure button is clicked, only the main toolbar
appears/disappears. I expect the bookmarks toolbar to be affected as well.

Reproducible: Always

Steps to Reproduce:
1. Open a new window
2. Make sure both the Toolbar and Bookmarks Toolbar are visible
3. Click the toolbar disclosure button on the top right of the window

Actual Results:  
The main toolbar disappears, but the bookmark toolbar remains.

Expected Results:  
I expect both toolbars to disappear. For comparison, OmniWeb and Internet
Explorer both behave in this manner. If the current design is intentional, then
I'd like some option to hide all toolbars, perhaps by Option-clicking the
toolbar disclosure button.

Workaround: Select "View -> Hide Bookmarks toolbar" from the menu.

Comment 1

16 years ago
Confirmed using Chimera/2002090913 on 10.1.5. It's possible that button should
also hide the Status Bar, if the ability to hide that bar is ever implemented
(see bug 159233).
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
See Bug 181473 too.

Comment 3

15 years ago
FYI, just in case one think to use a shortcut, some are used/defined by OS X.
All clicks are made on the Toolbar icon, white icon on top right of the window.
Be sure to open TWO windows and to see both toolbars, even partially.

Cmd        Click = Cycle through small/big icons with/out text and text types
    Option Click = Hide/Show the Toolbar of ALL Windows
Cmd Option Click = Show Customize Toolbar sheet

Ctrl-Cmd-Option-Click = Show Toolbar then Customize Toolbar sheet and when the
CT sheet is closed it will hide the Toolbar if it was hidden at click time.

Shift-Click in Finder is an Apple Bug, see Bug 162452

Comment 4

15 years ago
-->pinkerton
Assignee: brade → pinkerton
(Assignee)

Updated

15 years ago
Target Milestone: --- → Camino1.1

Comment 5

14 years ago
I do not agree, they are two separate toolbars. Each should be hiden seperatly.

Mike?

Comment 6

14 years ago
*** Bug 249661 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
I agree with Jasper. The OS X toolbar button, in all but a very few
circumstances, hides only the window’s main toolbar. When it’s used to hide all
toolbars a la the Finder, OmniWeb, or Firefox, it seems nonstandard and out of
place. 

Comment 8

13 years ago
It is inconsistent how a given program on my computer will behave:

* Finder transforms from a brushed-metal utility with a toolbar and sidebar to a
folder-viewer from the main pane of that utility.
* Mail.app removes its toolbar, leaving behind a thin status bar on top.  The
drawer is not hidden, but that's easy to hide.
* Most programs don't have the teardrop button.
* Each of Genius.app and FinkCommander removes its only toolbar, leaving behind
clickable column headings on top, tabular data as the viewport, and status
information on the bottom.

Generally, the toolbar button hides buttons for program functionality so that
its information is more visible.  So I think the  Bookmark Bar should hide with
the Toolbar.  It wouldn't look weird (as the Finder does) because based on
background color the Toolbar and the Bookmark Bar look like one complex of controls.
I disagree with this as well. Are we going to start hiding the tab bar as well
when the "toolbar disclosure button" is pushed? They are three separate
toolbars. Two can be hidden from the view menu and one from not having an tabs
open. We *could* go with Safari's method and remove the button altogether. Doing
so would solve this entire problem but still allow the user to hide the menus
via the context menu and view menu.

I suggest WONTFIX.

Comment 10

12 years ago
WONTFIX per comment 5, 7, 9, and my own personal opinion.

Pinkerton, feel free to reopen this if you feel strongly otherwise.

cl
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.