Closed Bug 1675996 Opened 4 months ago Closed 4 months ago

Searching empty strings does not work anymore

Categories

(Firefox :: Address Bar, defect)

Firefox 83
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: vogu66, Unassigned)

References

(Regression)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

Up till I updated to 83.0b6-1 (on Linux Manjaro), I would often go to the homepage of search engines just by typing its assigned name and hitting enter. (e.g. for YouTube I would type 'y' then 'enter').

Actual results:

Now what happens when I do that is that it either goes to the first website which begins with the name of the search engine in my bookmarks or it searches the string.

Expected results:

Well, before it would go to the homepage of the website. Now it seems when I hit "space" after the name of the search engine, a blue box with the selected engine appears. So I think it'd be neat if, once that blue box appears, hitting enter without any additional input would go to the homepage of the search engine (or search with %s replaced by an empty string or something like that, which I guess should redirect to the home page for most websites). (So, to keep my example, I'd say typing "y" then "space" then "enter", if "y" is the name of youtube.com, would go to youtube.com)

Component: Untriaged → Search
Status: UNCONFIRMED → NEW
Ever confirmed: true
Regressed by: 1658326
Type: enhancement → defect
Keywords: regression
Component: Search → Address Bar

This use-case was considered but discarded, going to the search engine homepage often is not useful, and it's also confusing for some users. There are other ways to achieve the same scope through autofill or bookmarks.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WONTFIX
Duplicate of this bug: 1676039
Duplicate of this bug: 1678190

Well, this is sad but I kind of understand.

Is there a way to customize the autofill function? I'd like to stop being redirected to "ytechb.com" instead of "youtube.com" every time I type "y+enter"...

Thank you for your answer, too.

Flags: needinfo?(mak)

(In reply to vogu66 from comment #4)

Is there a way to customize the autofill function? I'd like to stop being redirected to "ytechb.com" instead of "youtube.com" every time I type "y+enter"...

There isn't a specific way to influence the score in a stable way, but you can do a few things, first of all bookmark at least one page from youtube.com, second you can probably remove some history from ytechb.com, or remove bookmarks pointing to it, if you don't use them anymore.
autofill is based on a score that is influence by how recently and often a page has been visited, plus the fact pages in that domain are bookmarked.

We are discussing from some time about improvements to those rankings, that likely will happen in 2021.

Flags: needinfo?(mak)

Ok, thanks again!

I want to be able to type yt [keyword] as well as yt and be on youtube.com.
The solution for this if this issue really is closed for search engine keyword is to allow duplicate keyword to be used in bookmarks and search engines.

autofill is not reliable or won't learn fast enough or customizable especially in scenario where you may also frequently access ytetc.com

(In reply to Passawit Kaovilai from comment #7)

I want to be able to type yt [keyword] as well as yt and be on youtube.com.
The solution for this if this issue really is closed for search engine keyword is to allow duplicate keyword to be used in bookmarks and search engines.

I actually just tried that and it worked. (Thank you!) Although it may only be because my "youtube" search engine was installed back when mycroftproject.com was supported; but I believe if you use an extension (which admittedly may not be always possible without writing the addon) to add the search engine rather than a bookmark there would be no duplicate in said bookmarks and there would be no problem?

Duplicate of this bug: 1679294
Duplicate of this bug: 1680111

I have created the last one of the duplicates, my apologies. The search didn't really spit this one out.

(In reply to Marco Bonardo [:mak] from comment #1)

This use-case was considered but discarded, going to the search engine homepage often is not useful, and it's also confusing for some users. There are other ways to achieve the same scope through autofill or bookmarks.

Thank you for having considered this use case. However, I would like to comment on that, because the subsequent decision does not really make sense to me.

  • "going to the engine homepage [...] is not useful": I am not really sure what you mean by that. Shortcuts are intended for actual general search engines like e.g. google on the one hand, but also for specific resources like amazon or ebay on the other hand. This intention is made very clear by the pre-installed engines. A quick way to homepages for engines like those, as well as e.g. maps, wikipedia, community forums, even the bugzilla dashboard, etc. is indeed very useful.
  • "is *often not useful": Considering that people tend to use one engine to actually search the web (google, ecosia, duckduckgo, ...) and many sites of the latter type is in stark contrast to your statement
  • "it's also confusing for some users": The former behaviour of sending me to a page, the shortcut of which I am using, is very much what I expect of a shortcut to a search engine! It concede that it might be confusing that Fx is sending me the homepage, but at least it sends me somewhere!
  • "There are other ways to achieve the same scope through autofill ...": This is apparently not so easily done, as you lay out in #5.
  • "... or bookmarks": I got practically the former functionality by adding keywords to bookmarks. But for that I need to bookmark the site first, have them clutter by library and then make several additional clicks to configure the keyword via the library. (Bookmarking with the star in the address bar does not provide the keyword field...) This is way less intuitive than just sending me to the homepage when entering an empty search string, don't you think?

IMHO there was no actual need to remove the empty string search. The numerous duplicate reports show that this is apparently an issue in the power user community. How can I file a feature request? Maybe some others will back it up.

Thanks and best wishes!
Simon

(In reply to Simon from comment #12)

  • "going to the engine homepage [...] is not useful": I am not really sure what you mean by that. Shortcuts are intended for actual general search engines like e.g. google on the one hand, but also for specific resources like amazon or ebay on the other hand. This intention is made very clear by the pre-installed engines. A quick way to homepages for engines like those, as well as e.g. maps, wikipedia, community forums, even the bugzilla dashboard, etc. is indeed very useful.

Thank you for your feedback. By our research most of the times the user is effectively going to the search engine homepage to actually run a search. We worked (and are still) a lot around improving searching directly from Firefox, with the introduction of Search Mode that becomes even easier, and with suggestions in most cases. We're also working on vertical search to provide richer results specific to each engine.
We think our searching capabilities are at a point where it's not anymore strictly necessary to jump straight to the engine homepage, as I said that was confusing for users that did not undestand it's possible to search directly from Firefox.
We still have workarounds to cover the other needs, as I said Top Sites (that I forgot earlier, one can pin a site to the list and access Top Sites just focusing the urlbar), bookmarks and autofill are examples.

  • "There are other ways to achieve the same scope through autofill ...": This is apparently not so easily done, as you lay out in #5.

That was a special case, in most cases autofill does the right thing, you may have to type 2-3 chars intead of one for those few cases.
We'll be working on ranking improvements next year.

(In reply to Marco Bonardo [:mak] from comment #13)

By our research most of the times the user is effectively going to the search engine homepage to actually run a search.

Personally I'm one of them and I found very convenient the function of going to the homepage of the search engine so much that I used it many times a day but I also use the direct search, but for example with YouTube, Maps and Amazon they have homepages with variable content that if I don't know what to look for and I have already entered the keyword in the address bar, I press enter and I find the home of the site with the contents, without workaround, direct instant simple.

When this thing was removed I was very confused. For me an address bar should offer all possibilities to reach the content a user would like to reach. It does not create confusion, on the contrary, it adapts to a greater share of users. Better if it's customizable!

(In reply to AlienLogic from comment #14)

for example with YouTube, Maps and Amazon they have homepages with variable content that if I don't know what to look for and I have already entered the keyword in the address bar

Content discovery is a valid point, we'll discuss it later today. thanks.

I'll pile up with my own use case for which I filed bug 1678190 for: I have a keyword for this bugzilla. And while yes, technically, you could say that the page you get to is a search page because it has a search field, it also a large button for creating new bugs, and a bunch of other functionalities. I was able to either use "bz search string" to search for a specific bug or "bz" to get to the bugzilla main page. Now I'm getting Google results for the B'z Japanese band, because I've been using this for years, and it's hard to untrain my brain. And Firefox doesn't allow the same keyword to be used for search engines and bookmarks, so I can't even add bz as a keyword for the bookmark.

With all that being said, I also seem to remember that my use case above used to not be supported a very long time ago (only "bz search string" used to work), but became supported later, and it would probably be good to look back why it was added back then, and see why those reasons wouldn't still apply now.

(In reply to Mike Hommey [:glandium] from comment #16)

I'll pile up with my own use case for which I filed bug 1678190 for: I have a keyword for this bugzilla. And while yes, technically, you could say that the page you get to is a search page because it has a search field, it also a large button for creating new bugs, and a bunch of other functionalities. I was able to either use "bz search string" to search for a specific bug or "bz" to get to the bugzilla main page. Now I'm getting Google results for the B'z Japanese band, because I've been using this for years, and it's hard to untrain my brain. And Firefox doesn't allow the same keyword to be used for search engines and bookmarks, so I can't even add bz as a keyword for the bookmark.

Yes, muscle memory can be a problem, even if alternatives exist.
Note that we got many bug reports from users who complained about the old behavior, because they forgot they had set a keyword for certain words, and reported a bug because they didn't understand why typing "car" was going to "somecardomain.com" instead of searching Google for "car". I think I closed tens of those invalid bugs.
Even if we'd reimplement something like that, we should avoid reintroducing such an hidden and confusing behavior, and I'm not sure how, the only thing coming to my mind now would be to request typing a space after the keyword (basically enter search mode) and confirm an empty search. That's again sub-optimal and undiscoverable. We'll evaluate alternatives.

With all that being said, I also seem to remember that my use case above used to not be supported a very long time ago (only "bz search string" used to work), but became supported later, and it would probably be good to look back why it was added back then, and see why those reasons wouldn't still apply now.

I don't remember a reasoning around that, IIRC it was implemented by mistake. And we didn't think well about the case above where users got really confused when they didn't remember keywords set months or years ago. That bug still exists for bookmark keywords.

See comment #8 and #9.

You can create the old behavior by having a bookmark with the same keyword as the search engine.
See https://support.mozilla.org/en-US/kb/bookmarks-firefox

(In reply to Passawit Kaovilai from comment #18)

See comment #8 and #9.

You can create the old behavior by having a bookmark with the same keyword as the search engine.
See https://support.mozilla.org/en-US/kb/bookmarks-firefox

Firefox explicitly doesn't allow using the same keyword.

(In reply to Mike Hommey [:glandium] from comment #20)

(In reply to Passawit Kaovilai from comment #18)

See comment #8 and #9.

You can create the old behavior by having a bookmark with the same keyword as the search engine.
See https://support.mozilla.org/en-US/kb/bookmarks-firefox

Firefox explicitly doesn't allow using the same keyword.

it allows same keyword to be in both bookmark and search engine. This means that you won't rely on search engine keyword for going to homepage, but the bookmark keyword.

I suspect it may depend on the order you set them, it's possible the bookmarks ui checks for search engine keywords, but not the opposite.

(In reply to Marco Bonardo [:mak] from comment #15)

Content discovery is a valid point, we'll discuss it later today. thanks.
Always available.

(In reply to Passawit Kaovilai from comment #21)

it allows same keyword to be in both bookmark and search engine. This means that you won't rely on search engine keyword for going to homepage, but the bookmark keyword.

Another thing to take into consideration, while for search engine shortcuts you have all keywords grouped together in one bookmark settings page is not the same, yes you can group all bookmarked sites in one folder but it can be a very bad organization and you have to go to the bookmarks window to manage them.

A possible way to please everyone is adding an about:config setting that allow or not empty string research by keywords, may be set to false by default so for common users the behavior will be the new one.
I know this is a some more lines of code, but it's for more extensive customization, but that's Firefox's goal.

I hope you can find the best way to do this.

(In reply to Marco Bonardo [:mak] from comment #22)

I suspect it may depend on the order you set them, it's possible the bookmarks ui checks for search engine keywords, but not the opposite.

Oh boy. It's actually the opposite. about:preferences checks there isn't a bookmark with the same keyword when adding a keyword to a search engine. The bookmark ui doesn't check. What's up with this inconsistency?

Ok. So I think we can agree that the method I mentioned should be allowed to enable the old search engine keyword use case without confusing the end user on search keyword without space going to a bookmark.. Thus duplicate checks should only be done in the respective place it's being added into but not both.

(In reply to Mike Hommey [:glandium] from comment #24)

What's up with this inconsistency?

From a long time there's a plan to merge these features that are pretty much doing the same thing, thus nobody is really spending much time on those small details.

What if my Firefox is in Strict Mode where suggestions don't work, but I still want suggestions occasionally? In those cases I would usually type the keyword and press Enter.
I think a compromise in this case could be that pressing Space (which already highlights the selected search engine) and then Enter directs you to the homepage. At the moment, Space -> Enter does nothing, so I don't see how this would conflict with anything, and it makes logical sense. If anything, this behavior would be less confusing to me, a user.

Duplicate of this bug: 1685919

(In reply to dark2lightning from comment #29)

My apologies, I also did not find this bug report. For those who are interested, I found a workaround to restore the old behavior by setting browser.urlbar.update2 to false in about:config.

Please note that the update2 pref was only used for feature rollout and it will be removed in Firefox 86. See bug 1665049.

(In reply to dark2lightning from comment #29)

My apologies, I also did not find this bug report. For those who are interested, I found a workaround to restore the old behavior by setting browser.urlbar.update2 to false in about:config.

Finally, I had forgotten how comfortable the old behavior was.

(In reply to Harry Twyford [:harry] from comment #30)

Please note that the update2 pref was only used for feature rollout and it will be removed in Firefox 86. See bug 1665049.

I hope they will find a solution to satisfy both behaviors.

(In reply to dark2lightning from comment #29)

Something I've only just remembered thanks to dark2lightning's incredibly helpful tip is I used to be able to ctrl + a my address bar input to change it to something entirely different, in case I messed it up (e.g. entered "s" - for startpage - instead of "g" - for google). Can't do that either with the new behavior. Seems like a bunch of steps back with what seems to be zero steps forward (supposed "intuitiveness" is subjective, as this thread has proven).

(In reply to maybeoneday+bugzilla from comment #33)

Something I've only just remembered thanks to dark2lightning's incredibly helpful tip is I used to be able to ctrl + a my address bar input to change it to something entirely different,

I don't understand what you're speaking about, ctrl+a is Select All and it didn't change.

(In reply to Marco Bonardo [:mak] from comment #34)

it didn't change.

I suppose maybeoneday was referring to the fact that previously Ctrl + A also selected the keyword, making it easily replaceable. With the introduction of the new behavior, only the search query is selected, the keyword remains untouched and must be removed with another backspace hit.

I preferred the old behavior as well.

Thanks for the clarification. The keyword is considered part of the chosen workflow, it is called Search Mode because it's an alternate mode for the address bar the user can optionally enter. As such, it would be uncommon to exit a mode by select all. We consider Backspace and Escape sufficient handlers to exit search mode with the keyboard.

Duplicate of this bug: 1689318
You need to log in before you can comment on or make changes to this bug.