Closed Bug 1676041 Opened 3 months ago Closed 3 months ago

Selecting multiple messages causes Delete button to be masked with dark blue

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect

Tracking

(thunderbird_esr78 fixed, thunderbird83 affected, thunderbird84 affected)

RESOLVED FIXED
84 Branch
Tracking Status
thunderbird_esr78 --- fixed
thunderbird83 --- affected
thunderbird84 --- affected

People

(Reporter: greg, Assigned: Paenglab)

Details

(Keywords: regression)

Attachments

(4 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0

Steps to reproduce:

I selected more than one message for deletion after updating to the most recent TB 78.4.1 (32-bit).

Actual results:

The messages were selected, but the Delete button immediately below the message list was obscured by the background of the area containing the Delete button to change to the same color as the selected messages. On my system, that is dark blue. I can barely see the Delete button. Clicking the Delete button does the right thing.

Expected results:

Either the background of that area should not be turned dark blue, or the Delete lettering should be changed from black to a lighter color that can be seen over the dark blue background.

John, you can test this on Windows 10 High Contrast themes.

With HC-themes there is no difference between hovered and active buttons. Unfortunately we can't differ between Classic and HC-themes and Classic will also not have the hover active difference.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9186526 - Flags: review?(john)
Keywords: regression
Attached image before-patch.PNG
Attached image after-patch.PNG

Code of course looks fine. Is the change in the posted screenshots the expected outcome?

(In reply to John Bieling (:TbSync) from comment #4)

Code of course looks fine. Is the change in the posted screenshots the expected outcome?

Yes, it's to make the buttons stand out of the background. Black is here the normal unhovered button background.

Attachment #9186526 - Flags: review?(john) → review+
Target Milestone: --- → 84 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/ecb3513ae547
Fix multimessage toolbarbuttons on Classic and High Contrast themes. r=TbSync DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

Comment on attachment 9186526 [details] [diff] [review]
1676041-multimessage-buttons.patch

[Approval Request Comment]
User impact if declined: Not clearly visible buttons on multimessage header.
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9186526 - Flags: approval-comm-beta?

[Approval Request Comment]
User impact if declined: Not clearly visible buttons on multimessage header.
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9186629 - Flags: approval-comm-esr78?

Comment on attachment 9186629 [details] [diff] [review]
1676041-multimessage-buttons-ESR.patch

[Triage Comment]
Approved for esr78

Attachment #9186629 - Flags: approval-comm-esr78? → approval-comm-esr78+

Comment on attachment 9186526 [details] [diff] [review]
1676041-multimessage-buttons.patch

[Triage Comment]
We aren't building another build for 83 beta, so this will appear in 84 beta

Attachment #9186526 - Flags: approval-comm-beta? → approval-comm-beta-

Looks okay to me in my test of the 78.5.0 release candidate on Windows 10 (20H2).

You need to log in before you can comment on or make changes to this bug.