New messages indicator still flagged when filter "Mark as read" is applied

RESOLVED DUPLICATE of bug 179556

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 179556
16 years ago
14 years ago

People

(Reporter: James McCaw, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
If you have a filter which marks a message as read, the following happens on my
system:

The folder view on the left goes bold, and indicates that there is, say, one new
unread message - Exactly the same behaviour as if the filter had not been applied.

When you click on the folder, the message then changes to having been read,
without you having to click on the message - so the filter is marking the
message as read, but the folder doesn't realise until the folder is clicked on.

This is in Mozilla 1.0 - I don't have permission to install updates so I can't
check it on a newer build. Sorry.

Updated

16 years ago
QA Contact: olgam → laurel

Comment 1

16 years ago
This still shows up on 1.3a Linux.

Comment 2

15 years ago
*** Bug 200540 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
James McCaw, are you still seeing this bug (have you had a chance to upgrade 
from 1.0 yet)?  This appears to be a duplicate of, or at least closely related 
to, Bug 107206.

Did your report mean to indicate that when the folder is updated to bold, the 
number of new messages appears after it?  What about the green arrow?  I ask 
because I'm working on another very similar bug, for which I have duplicated 
that the folder goes bold but without indicating a number of messages.  

Comment 4

15 years ago
Additional possible duplicate:  Bug 179556.
(Reporter)

Comment 5

15 years ago
Mike, I have read over the comments for the bugs you refer to and those bugs do
seem related to what I'm reporting. I suspect what I'm seeing is due to the same
problem - but as far as I can tell, what I'm reporting isn't exactly reported
anywhere else (I also see the green arrow behaviour referred to).

I will try to clarify what I see in more detail than my initial comment
associated with this bug.

As background, I like to filter my sent messages, so rather than putting sent
mail in "Sent Mail", I Bcc: my sent mail to myself and then have filters which
say "If sender is me and To: is john@john, put message in "john's folder" and
mark as read.

For simplicity, assume the destination folder is currently empty, or at least
has no unread messages in it.

I would expect this action to put my sent mail in "john's folder" but not alert
me, not beep, not put a green arrow and not make the folder bold and definitely
not make the message itself bold. After all, the filter is marking the mail as
read, so why would I want to be told about it?

Mozilla's current behaviour is not this, but it is a sort of broken version of
it. When a message goes through the filter mechanism described above, the folder
the mail is delivered to becomes bold and the message count indicator is
incremented. This behaviour is wrong as far as I'm concerned.

When you click on the folder (not the message) the folder changes to unbold and
indicates no messages unread. The contained message, as expected, is already
marked as read. It takes this click on the folder to get the folder to be in the
state I would expect it to be in from the beginning, that is not bold and zero
unread messages.

It seems that the folder's status is only updated to the correct status when you
click on it, and until that time, it simply is showing the wrong status. There
are no unread messages in the folder, yet it is bold and displays a number.

I hope that clarifies things. It doesn't seem to be exactly what you are working
on though.

This bug still exists in 1.3, 1.3b

Comment 6

15 years ago
Bug 179556 does appear to be a duplicate ( at least in my initial filing of it
), although later comments from a different person describe possibly a different
problem.

Confirm still occuring in Moz Win2000 2003042112. In my case I'm using an IMAP
server over a slow link, so I'm seeing a somewhat slower motion version of the
problem. :)

Without reading the code, but from my feel of it, the following is happening.

1. Message captured by filter.
2. Unread message moved to different folder.
3. Unread message count for folder incremented ( maybe checking with server,
maybe not, the process is quite fast ).
4. Message marked as "unread".
5. Counter NOT updated to move the counter back down.

At least, that's where I'd be looking if I'd written the code to do that sort of
thing.

Of course, the bug summary doesn't seem to match it...

I'd describe it as either as

"Counter updated incorrectly when filter moves and marks as unread"

or possibly

"Marking message unread in unselected folder does not decrement unread message
count".

Or course, my feel for the quickest, hackiest, way to fix this would be to move
"mark as unread" BEFORE "move to folder" in the filter task order. I'll bet 10
bucks to folder moved "to" doesn't increment it's counter.

But then coding mozilla is beyond my scope, I have enough to do :)

Mark Bug 179556 as a duplicate if you want, or the other way around... either
way I'm fine.

Comment 7

15 years ago
James McCaw, two more questions:  IMAP or POP account?  And, what theme, if any,
do you have installed?
(Reporter)

Comment 8

15 years ago
This is an IMAP connection, and seeing people are talking about response time, I
get the same behaviour at work over the LAN (100Mbit) and from home (56k modem).

I use the stock standard modern theme.

Adam Kennedy's comment (#6) seems like a reasonable explanation.

Comment 9

15 years ago
Duping this to the newer (but already confirmed) 179556.

*** This bug has been marked as a duplicate of 179556 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.