Mozilla 1.1 Does Not Install Unless IE Is Also Installed

VERIFIED DUPLICATE of bug 135570

Status

SeaMonkey
Installer
VERIFIED DUPLICATE of bug 135570
15 years ago
13 years ago

People

(Reporter: Scott Hallock, Assigned: dveditz)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
On Windows 95 950.6 (the very first retail Win95, not OSR 1, 2, or 2.5), Mozilla
will not install unless Internet Explorer (I'm not sure of version requirements,
IE 5.5 got things going for me) is also installed.  I'll leave the snide
comments for the peanut gallery.

Hardware: An old Pentium with 32MB of RAM.  I can give more details on request,
but I don't think hardware makes a difference, here.

Software: Windows 95 Version 4.00.950

Repro Steps:

1. Download mozilla-win32-1.1-installer.exe or
mozilla-win32-1.1-stub-installer.exe from ftp.mozilla.org and execute the
downloaded binary on a machine running a freshly installed copy of Windows 95
950.6 that does not have Internet Explorer installed.

2. Accept all the defaults in the installation wizard and begin the install.

Expected Result:

Mozilla 1.1 installs and runs.

Actual result:

Immediately after the "Verifiying Archive Integrity" message box, an error
message box pops up saying that xpistub.dll could not be loaded from a deep
subdirectory of %windir%\temp.  You may also notice an overwhelming sense of irony.

Workaround:

Install IE 5.5 and repeat the above steps.  Mozilla will install just fine.

The Mozilla .EXEs in question aren't corrupt because they install if IE is
installed, and they install just fine on Win2K, as well.
Have you installed the winssock2 update for win95 ?
(Reporter)

Comment 2

15 years ago
I didn't install any updates, but would that really prevent the installer from
finding a file?  I'll see if I can find the winsock update anywhere and retry
the installtion.
FYI:
http://www.microsoft.com/windows95/downloads/contents/WUAdminTools/S_WUNetworkingTools/W95Sockets2/Default.asp

Comment 4

15 years ago
could you try to remove mozilla and then reinstall mozilla on you original
system (without ie5)
and then attach the install log files, which are located at the
mozilla.org/mozilla folder

have we heard about this requirement before? do we use some ie specific dll's to
uncompress or something?
URL: N/A
Severity: major → normal
(Reporter)

Comment 5

15 years ago
I'll get those logs this evening (US Mountain Time) and then try with the
Winsock update.
Yes we need the winsock2 update on win95a.
Mozilla will not work without this !
I dunno if this missing update is the problem with the installer but mozilla
doesn't depend on IE (only for imported IE favorites) and the winsock2 update is
one of the main API differences between Win95a and win95b.

Comment 7

15 years ago
this looks like duplicate of bug 135570

*** This bug has been marked as a duplicate of 135570 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 8

15 years ago
Verified as a dupe of bug 135570. Thanks Grace!
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → ktrina
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.