Open Bug 1676533 Opened 10 months ago Updated 9 months ago

Automatically determine "base revision" hashes during |mach artifact|

Categories

(Firefox Build System :: Mach Core, enhancement, P3)

enhancement

Tracking

(firefox85 affected)

REOPENED
Tracking Status
firefox85 --- affected

People

(Reporter: mhentges, Assigned: glandium, NeedInfo)

References

Details

(Keywords: in-triage)

Attachments

(1 file)

As noted by bugs like 1676107, sometimes there's dirty files in-tree but it's not obvious to developers why that's causing mach artifact to fail.

As discussed in the most-recent build peers meeting, when calculating artifact hashes, we should use the state of input files as they are on the current "base revision", rather than the current state on the file system.

Random thought: you may want to list the outgoing/changed files and only consult the VCS for THOSE files, and keep the existing logic for the unchanged files. Otherwise it's probably going to be prohibitively slow with Mercurial.

Severity: -- → S3
Keywords: in-triage
Priority: -- → P3
Assignee: nobody → rstewart

This enables mach artifact and mach bootstrap to not fail due to local changes.

Pushed by rstewart@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/101792a18a59
Consult the base revision for file hashes instead of the on-disk files in `mach artifact` r=ahal
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
Regressions: 1677918
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: 85 Branch → ---
Flags: needinfo?(rstewart)
Regressions: 1678064
Pushed by rstewart@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5153f0eaf518
Consult the base revision for file hashes instead of the on-disk files in `mach artifact` r=ahal
Status: REOPENED → RESOLVED
Closed: 10 months ago10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
Regressions: 1679382
No longer regressions: 1679382
Flags: needinfo?(rstewart)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

It broke pushing changes to toolchain scripts to try: no toolchain builds are triggered by the decision task.

Assignee: rstewart → mh+mozilla

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:glandium, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(mh+mozilla)
You need to log in before you can comment on or make changes to this bug.