Closed Bug 1676696 Opened 2 years ago Closed 2 years ago

Intermittent toolkit/components/printing/tests/browser_preview_print_simplify_non_article.js | Found a tab after previous test timed out: about:printpreview -

Categories

(Toolkit :: Printing, defect, P5)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1679403

People

(Reporter: intermittent-bug-filer, Unassigned)

References

Details

(Keywords: intermittent-failure)

Filed by: apavel [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=321468575&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/CzIqZFivQpidFBc0TAQNbg/runs/0/artifacts/public/logs/live_backing.log


[task 2020-11-11T16:15:24.343Z] 16:15:24     INFO - TEST-START | toolkit/components/printing/tests/browser_preview_print_simplify_non_article.js
[task 2020-11-11T16:15:24.400Z] 16:15:24     INFO - GECKO(13795) | [Child 14511: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0x7f72406f1000 == 2 [pid = 14511] [id = 0] [url = about:blank]
[task 2020-11-11T16:15:24.400Z] 16:15:24     INFO - GECKO(13795) | [Child 14511: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0x7f723a44f800 == 1 [pid = 14511] [id = 1] [url = https://example.com/browser/toolkit/components/printing/tests/file_coop_header.html]
[task 2020-11-11T16:15:24.400Z] 16:15:24     INFO - GECKO(13795) | [Child 14511: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0x7f723a4a4800 == 0 [pid = 14511] [id = 2] [url = about:printpreview]
[task 2020-11-11T16:15:24.436Z] 16:15:24     INFO - GECKO(13795) | [Child 14513: Main Thread]: I/DocShellAndDOMWindowLeak ++DOCSHELL 0x7f0a658f5800 == 1 [pid = 14513] [id = 0]
[task 2020-11-11T16:15:24.457Z] 16:15:24     INFO - GECKO(13795) | Waiting for browser load
[task 2020-11-11T16:15:24.457Z] 16:15:24     INFO - GECKO(13795) | Waiting for browser state change
[task 2020-11-11T16:15:24.477Z] 16:15:24     INFO - GECKO(13795) | [Child 14513: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 1 (0x7f0a5f6ce040) [pid = 14513] [serial = 1] [outer = (nil)]
[task 2020-11-11T16:15:24.485Z] 16:15:24     INFO - GECKO(13795) | [Child 14513: Main Thread]: I/DocShellAndDOMWindowLeak ++DOMWINDOW == 2 (0x7f0a5f648c00) [pid = 14513] [serial = 2] [outer = 0x7f0a5f6ce040]
[task 2020-11-11T16:15:24.507Z] 16:15:24     INFO - GECKO(13795) | [Child 14511: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 8 (0x7f723a4a5800) [pid = 14511] [serial = 7] [outer = (nil)] [url = about:blank]
[task 2020-11-11T16:15:24.507Z] 16:15:24     INFO - GECKO(13795) | [Child 14511: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 7 (0x7f723a4cf740) [pid = 14511] [serial = 6] [outer = (nil)] [url = https://example.com/browser/toolkit/components/printing/tests/file_coop_header.html]
[task 2020-11-11T16:15:24.507Z] 16:15:24     INFO - GECKO(13795) | [Child 14511: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 6 (0x7f723a4cf040) [pid = 14511] [serial = 1] [outer = (nil)] [url = about:blank]
[task 2020-11-11T16:15:24.508Z] 16:15:24     INFO - GECKO(13795) | [Child 14511: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 5 (0x7f723a4cf200) [pid = 14511] [serial = 3] [outer = (nil)] [url = https://example.com/browser/toolkit/components/printing/tests/file_coop_header.html]
[task 2020-11-11T16:15:24.509Z] 16:15:24     INFO - GECKO(13795) | [Child 14511: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 4 (0x7f723a4ab000) [pid = 14511] [serial = 8] [outer = (nil)] [url = about:printpreview]
[task 2020-11-11T16:15:24.511Z] 16:15:24     INFO - GECKO(13795) | [Child 14511: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 3 (0x7f723a756800) [pid = 14511] [serial = 5] [outer = (nil)] [url = https://example.com/browser/toolkit/components/printing/tests/file_coop_header.html]
[task 2020-11-11T16:15:24.512Z] 16:15:24     INFO - GECKO(13795) | [Child 14511: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 2 (0x7f723a4ae400) [pid = 14511] [serial = 4] [outer = (nil)] [url = about:blank]
[task 2020-11-11T16:15:24.512Z] 16:15:24     INFO - GECKO(13795) | [Child 14511: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 1 (0x7f723a449800) [pid = 14511] [serial = 2] [outer = (nil)] [url = about:blank]
[task 2020-11-11T16:15:24.513Z] 16:15:24     INFO - GECKO(13795) | [Child 14511: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 0 (0x7f723a4abc00) [pid = 14511] [serial = 9] [outer = (nil)] [url = https://example.com/browser/toolkit/components/printing/tests/file_coop_header.html]
[task 2020-11-11T16:15:24.569Z] 16:15:24     INFO - GECKO(13795) | [Child 14511, Main Thread] WARNING: Extra shutdown CC: 'i < NORMAL_SHUTDOWN_COLLECTIONS', file /builds/worker/checkouts/gecko/xpcom/base/nsCycleCollector.cpp:3359
[task 2020-11-11T16:15:24.626Z] 16:15:24     INFO - GECKO(13795) | [Child 14511, Main Thread] WARNING: NS_ENSURE_TRUE(Preferences::InitStaticMembers()) failed: file /builds/worker/checkouts/gecko/modules/libpref/Preferences.cpp:4287
[task 2020-11-11T16:15:24.666Z] 16:15:24     INFO - GECKO(13795) | Saw state f0001 and status 0

[task 2020-11-11T16:15:41.685Z] 16:15:41     INFO - GECKO(13795) | [Parent 13795: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 13 (0x7f28df5b2400) [pid = 13795] [serial = 132] [outer = (nil)] [url = about:blank]
[task 2020-11-11T16:15:41.685Z] 16:15:41     INFO - GECKO(13795) | [Parent 13795: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 12 (0x7f28ed6d3400) [pid = 13795] [serial = 130] [outer = (nil)] [url = about:blank]
[task 2020-11-11T16:16:54.355Z] 16:16:54     INFO - TEST-INFO | started process screentopng
[task 2020-11-11T16:16:54.528Z] 16:16:54     INFO - TEST-INFO | screentopng: exit 0
[task 2020-11-11T16:16:54.528Z] 16:16:54     INFO - Buffered messages logged at 16:15:24
[task 2020-11-11T16:16:54.528Z] 16:16:54     INFO - Entering test bound set_simplify_and_reader_pref
[task 2020-11-11T16:16:54.528Z] 16:16:54     INFO - Leaving test bound set_simplify_and_reader_pref
[task 2020-11-11T16:16:54.528Z] 16:16:54     INFO - Entering test bound switch_print_preview_browsers
[task 2020-11-11T16:16:54.528Z] 16:16:54     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.com/browser/toolkit/components/printing/tests/simplifyNonArticleSample.html" line: 0}]
[task 2020-11-11T16:16:54.529Z] 16:16:54     INFO - Buffered messages logged at 16:15:25
[task 2020-11-11T16:16:54.529Z] 16:16:54     INFO - TEST-PASS | toolkit/components/printing/tests/browser_preview_print_simplify_non_article.js | Should have initial content. - "Non article title" == "Non article title" - 
[task 2020-11-11T16:16:54.529Z] 16:16:54     INFO - Buffered messages logged at 16:15:26
[task 2020-11-11T16:16:54.530Z] 16:16:54     INFO - Console message: [JavaScript Error: "TypeError: can't access property "windowGlobalChild", thisWindow is null" {file: "resource://gre/actors/PrintingChild.jsm" line: 174}]
[task 2020-11-11T16:16:54.530Z] 16:16:54     INFO - Buffered messages finished
[task 2020-11-11T16:16:54.531Z] 16:16:54     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/printing/tests/browser_preview_print_simplify_non_article.js | Test timed out - 
[task 2020-11-11T16:16:54.531Z] 16:16:54     INFO - GECKO(13795) | MEMORY STAT | vsize 3157MB | residentFast 359MB | heapAllocated 98MB
[task 2020-11-11T16:16:54.531Z] 16:16:54     INFO - TEST-OK | toolkit/components/printing/tests/browser_preview_print_simplify_non_article.js | took 90043ms
[task 2020-11-11T16:16:54.532Z] 16:16:54     INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-11-11T16:16:54.533Z] 16:16:54     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/printing/tests/browser_preview_print_simplify_non_article.js | Found a tab after previous test timed out: about:printpreview - 
[task 2020-11-11T16:16:54.533Z] 16:16:54     INFO - Not taking screenshot here: see the one that was previously logged
[task 2020-11-11T16:16:54.534Z] 16:16:54     INFO - TEST-UNEXPECTED-FAIL | toolkit/components/printing/tests/browser_preview_print_simplify_non_article.js | Found a tab after previous test timed out: about:printpreview - 
[task 2020-11-11T16:16:54.534Z] 16:16:54     INFO - GECKO(13795) | JavaScript error: chrome://browser/content/tabbrowser-tabs.js, line 1097: TypeError: can't access property "closing", selectedTab is null
[task 2020-11-11T16:16:54.536Z] 16:16:54     INFO - Console message: [JavaScript Error: "TypeError: can't access property "closing", selectedTab is null" {file: "chrome://browser/content/tabbrowser-tabs.js" line: 1097}]
[task 2020-11-11T16:17:02.482Z] 16:17:02     INFO - GECKO(13795) | [Child 14513: Main Thread]: I/DocShellAndDOMWindowLeak --DOCSHELL 0x7f0a5e7a4800 == 3 [pid = 14513] [id = 3] [url = about:printpreview]
[task 2020-11-11T16:17:06.577Z] 16:17:06     INFO - GECKO(13795) | [Child 14513: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 7 (0x7f0a5f6cee40) [pid = 14513] [serial = 11] [outer = (nil)] [url = about:printpreview]
[task 2020-11-11T16:17:10.628Z] 16:17:10     INFO - GECKO(13795) | [Child 14513: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 6 (0x7f0a5e7a8000) [pid = 14513] [serial = 13] [outer = (nil)] [url = about:printpreview]
[task 2020-11-11T16:21:13.468Z] 16:21:13     INFO - Console message: [JavaScript Error: "Unknown Collection "main/nimbus-desktop-experiments"" {file: "resource://services-settings/RemoteSettingsClient.jsm" line: 160}]
[task 2020-11-11T16:21:13.468Z] 16:21:13     INFO - UnknownCollectionError@resource://services-settings/RemoteSettingsClient.jsm:160:5
[task 2020-11-11T16:21:13.468Z] 16:21:13     INFO - sync@resource://services-settings/RemoteSettingsClient.jsm:470:13
[task 2020-11-11T16:21:13.468Z] 16:21:13     INFO - 
[task 2020-11-11T16:24:46.979Z] 16:24:46     INFO - GECKO(13795) | [Parent 13795, Main Thread] WARNING: 'NS_FAILED(aRv)', file /builds/worker/checkouts/gecko/netwerk/ipc/NeckoParent.cpp:914
[task 2020-11-11T16:24:46.995Z] 16:24:46     INFO - GECKO(13795) | [Child 13981, Main Thread] WARNING: NS_ENSURE_TRUE(mRequest) failed: file /builds/worker/checkouts/gecko/netwerk/base/nsBaseChannel.cpp:928
[task 2020-11-11T16:25:13.451Z] 16:25:13     INFO - GECKO(13795) | 1605111913440	addons.xpi	ERROR	System addon update list error Error: got node name: html, expected: updates
[task 2020-11-11T16:25:13.452Z] 16:25:13     INFO - Console message: [JavaScript Error: "1605111913440	addons.xpi	ERROR	System addon update list error Error: got node name: html, expected: updates" {file: "resource://gre/modules/Log.jsm" line: 723}]
[task 2020-11-11T16:25:13.452Z] 16:25:13     INFO - append@resource://gre/modules/Log.jsm:723:12
[task 2020-11-11T16:25:13.453Z] 16:25:13     INFO - log@resource://gre/modules/Log.jsm:379:16
[task 2020-11-11T16:25:13.453Z] 16:25:13     INFO - error@resource://gre/modules/Log.jsm:387:10
[task 2020-11-11T16:25:13.453Z] 16:25:13     INFO - updateSystemAddons/res<@resource://gre/modules/addons/XPIInstall.jsm:4015:25
[task 2020-11-11T16:25:13.453Z] 16:25:13     INFO - 
[task 2020-11-11T16:31:23.466Z] 16:31:23     INFO - Buffered messages finished
[task 2020-11-11T16:31:23.467Z] 16:31:23    ERROR - TEST-UNEXPECTED-TIMEOUT | toolkit/components/printing/tests/browser_preview_print_simplify_non_article.js (finished) | application timed out after 370 seconds with no output
[task 2020-11-11T16:31:23.467Z] 16:31:23    ERROR - Force-terminating active process(es).```
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1679403
You need to log in before you can comment on or make changes to this bug.