Closed Bug 1676820 Opened 2 years ago Closed 2 years ago

We should have a one-click way to access lockwise passwords

Categories

(Toolkit :: Password Manager, enhancement)

75 Branch
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1120684

People

(Reporter: Yoric, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:75.0) Gecko/20100101 Firefox/75.0

Steps to reproduce:

  1. I have a login/password to foo.example.org. This login/password combo is known to Firefox Password Manager/Lockwise.
  2. I attempt to login on bar.example.org, which uses the same login/password. However, this is a different domain so Lockwise cannot suggest anything useful.
  3. When I click on the login or password fields, nothing useful happens.

Expected results:

  1. When I click on the login or password fields, I see a menu entry "see all logins". This opens about:logins.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Password Manager
Product: Firefox → Toolkit

Hi Yoric, thanks for filing this. Given your scenario, there should be an autocomplete field on bar.example.org given that you have a login foo.example.org. If I understand your scenario correctly, Bug 589628 should have fixed this. If I'm not understanding this correctly and these example sites are related realms instead, then we can duplicate against Bug 1120684.

Are you able to disclose the actual sites where this behavior is occurring? There might be some other logic going on under the hood that is preventing the autocomplete from showing. Additionally, enabling the password manager debug logs and attaching those logs would be beneficial in figuring our this issue.

Flags: needinfo?(D.O.Teller+bugspam)

I'm going to dupe to Bug 1120684, which I think would solve the issue being described here. Note that the 2 specific origins in comment 0 would actually give the expected result, but for related-but-not-eTLD+1 origins, it will not.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1120684

Sorry for not responding earlier, Bugzilla seems to have stopped bugspamming me, I need to check the config.

It looks like Bug 1120684 would indeed help.

Flags: needinfo?(D.O.Teller+bugspam)
You need to log in before you can comment on or make changes to this bug.