Closed Bug 1676865 Opened 2 months ago Closed 2 months ago

Intermittent comm/mail/test/browser/openpgp/browser_keyWizard.js | uncaught exception - TypeError: can't access property "resizeVertically", gSubDialog._topDialog is undefined at resizeDialog/<@chrome://openpgp/content/ui/keyWizard.js:533:7

Categories

(Thunderbird :: General, defect, P5)

Tracking

(thunderbird_esr78 fixed, thunderbird84 fixed)

RESOLVED FIXED
85 Branch
Tracking Status
thunderbird_esr78 --- fixed
thunderbird84 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: aleca)

Details

(Keywords: intermittent-failure)

Attachments

(1 file, 1 obsolete file)

Filed by: mkmelin [at] iki.fi
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=321553429&repo=comm-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/RawiaY91Tx69DsBpeRPewQ/runs/0/artifacts/public/logs/live_backing.log


Don't think I saw it before https://treeherder.mozilla.org/jobs?repo=comm-central&selectedTaskRun=RawiaY91Tx69DsBpeRPewQ.0&revision=1104390ebf76c917b35d2fbee3a9f31a62ac92c2```

Seems to be a common issue on OSX

Flags: needinfo?(alessandro)

Thanks for the ping, I'll take care of it.

Flags: needinfo?(alessandro)
Assignee: nobody → alessandro
Status: NEW → ASSIGNED
Attached patch 1676865-keywizard-test.diff (obsolete) — Splinter Review

Very hard to reproduce locally as it seems to be related to an issue only happening when the test runs quicker than the transition timeout and closes the subdialog before the resizeDialog() got a chance to run.

This should fix it.
We could implement a smarter way waiting for the transition to end and the resize to happen, but that means delaying the test unnecessarily.
Do you think we should do that?

Meanwhile, here's a try run with the current patch: https://treeherder.mozilla.org/jobs?repo=try-comm-central&revision=6ab54522622c626a98439f74d828d6f0723a0472

Attachment #9188196 - Flags: review?(mkmelin+mozilla)

I forgot the macOS tests don't run if I only pick mochitests.
I launched another try-run with all the tests, just to be sure we're not breaking anything else: https://treeherder.mozilla.org/jobs?repo=try-comm-central&revision=2183bdf6c3d0e4690c0c5240d6eca78d74c59b5d

Comment on attachment 9188196 [details] [diff] [review]
1676865-keywizard-test.diff

Still failing, I'll try another solution.

Attachment #9188196 - Flags: review?(mkmelin+mozilla) → review-

Maybe the issue is not the test or the KeyWizard itself but rather the RNP library not running on treeherder?
https://treeherder.mozilla.org/logviewer?job_id=322006631&repo=try-comm-central&lineNumber=3197-3198

Nevermind, the RNP library doesn't load with artifact builds, that's why everything was failing.

Yeah mac artifacts not working with rnp is bug 1675160.

Comment on attachment 9188196 [details] [diff] [review]
1676865-keywizard-test.diff

Review of attachment 9188196 [details] [diff] [review]:
-----------------------------------------------------------------

::: mail/extensions/openpgp/content/ui/keyWizard.js
@@ +527,2 @@
>  function resizeDialog() {
>    // Timeout to trigger the dialog resize after the reveal animation completed.

Well you do have the transitionend event, so maybe hook up to that?

I'll also note there seems to be a lot of eventListener setup+removals for that event here. If it's just going to be used once, just pass in the { once: true } option to addEventListener instead, could make the code easier to undestand
Comment on attachment 9188943 [details] [diff] [review]
1676865-keywizard-test.diff

Review of attachment 9188943 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin
Attachment #9188943 - Flags: review?(mkmelin+mozilla) → review+
Target Milestone: --- → 85 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/a141d1237293
Fix intermittent comm/mail/test/browser/openpgp/browser_keyWizard.js test failure. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Should this get uplifted to 84 beta?

Comment on attachment 9188943 [details] [diff] [review]
1676865-keywizard-test.diff

Review of attachment 9188943 [details] [diff] [review]:
-----------------------------------------------------------------

Fix intermittent test failure on beta.
Attachment #9188943 - Flags: approval-comm-beta?

Comment on attachment 9188943 [details] [diff] [review]
1676865-keywizard-test.diff

[Triage Comment]
Approved for beta

Attachment #9188943 - Flags: approval-comm-beta? → approval-comm-beta+

I think I saw this one on esr78 today with a local build. I suggest to target an uplift to esr78, too.

saw this again in a local build

are we ready to request esr78 approval?

(In reply to Kai Engert (:KaiE:) from comment #20)

are we ready to request esr78 approval?

Yes, I'll do that, I was waiting for the beta release and potential intermittent issues there.

Comment on attachment 9188943 [details] [diff] [review]
1676865-keywizard-test.diff

[Approval Request Comment]
Fix intermittent test failure on esr 78.

Attachment #9188943 - Flags: approval-comm-esr78?

Comment on attachment 9188943 [details] [diff] [review]
1676865-keywizard-test.diff

[Triage Comment]
Approved for esr78

Attachment #9188943 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.