Closed Bug 1676882 Opened 11 months ago Closed 10 months ago

Crash in [@ std::io::stdio::_eprint] from glean ping.rs

Categories

(Toolkit :: Telemetry, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1677073
Tracking Status
firefox-esr78 --- unaffected
firefox82 --- unaffected
firefox83 --- unaffected
firefox84 --- affected

People

(Reporter: aryx, Assigned: emilio)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

Crash report: https://crash-stats.mozilla.org/report/index/7243dc69-de7e-405e-9983-17de00201108

MOZ_CRASH Reason: failed printing to stderr: O pipe está sendo fechado. (os error 232)

Top 10 frames of crashing thread:

0 xul.dll RustMozCrash mozglue/static/rust/wrappers.cpp:16
1 xul.dll mozglue_static::panic_hook mozglue/static/rust/lib.rs:89
2 xul.dll core::ops::function::Fn::call<fn ../18bf6b4f01a6feaf7259ba7cdae58031af1b7b39/library/core/src/ops/function.rs:227
3 xul.dll std::panicking::rust_panic_with_hook ../18bf6b4f01a6feaf7259ba7cdae58031af1b7b39//library/std/src/panicking.rs:573
4 xul.dll std::panicking::begin_panic_handler::{{closure}} ../18bf6b4f01a6feaf7259ba7cdae58031af1b7b39//library/std/src/panicking.rs:476
5 xul.dll std::sys_common::backtrace::__rust_end_short_backtrace<closure-0, !> ../18bf6b4f01a6feaf7259ba7cdae58031af1b7b39//library/std/src/sys_common/backtrace.rs:153
6 xul.dll std::panicking::begin_panic_handler ../18bf6b4f01a6feaf7259ba7cdae58031af1b7b39//library/std/src/panicking.rs:475
7 xul.dll std::panicking::begin_panic_fmt ../18bf6b4f01a6feaf7259ba7cdae58031af1b7b39//library/std/src/panicking.rs:429
8 xul.dll std::io::stdio::_eprint ../18bf6b4f01a6feaf7259ba7cdae58031af1b7b39//library/std/src/io/stdio.rs:919
9 xul.dll env_logger::{{impl}}::log third_party/rust/env_logger-0.6.2/src/lib.rs:821
Flags: needinfo?(jrediger)

Seems that's more an issue of the underlying log library (env_logger), used from geckologger.
This time we're just the lucky ones to get the crash because we logged an error.
This would need to be fixed in env_logger to not use the eprint code path, which aborts, or geckologger would need to not use env_logger and implement all this by itself.

I can try to reach out to whoever does geckologger to see what the solution would be. Leaving my ni? until then.

Assignee: nobody → emilio
Attached file GitHub Pull Request
Depends on: 1677073
Flags: needinfo?(jrediger)

Jan-Erik this looks like it's awaiting your review on emilio's PR?

Flags: needinfo?(jrediger)

Not really (still gave it approval now), but requires a merge from the maintainers (it's not a mozilla project).
If this is really critical we could patch it in m-c while we wait for an upstream release.

Flags: needinfo?(jrediger)

and just as I write that it has been merged.

Bug 1677073 will fix that in the end.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1677073
See Also: → 1685916
You need to log in before you can comment on or make changes to this bug.