[dogfood]crash when large message download exceeds memory/diskspace

VERIFIED INVALID

Status

MailNews Core
Backend
P3
normal
VERIFIED INVALID
18 years ago
9 years ago

People

(Reporter: Doctor Dan, Assigned: Marek Z. Jeziorek)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

18 years ago
This is my follow up on a previous note about the infamous
"....illegal operation and will shut down" message.

After a day and a half of chasing my tail, I went back to see what
changed "overnight." The last thing I did was download a bunch of
e-mails that came to me.  As it turned out, the inbox was "fuller than
full."  In essence, the ONE GIGANTIC file exceeded my memory
capabilities.  I moved the file and everything seems to be OK at the
moment.

Which brings me to this suggestion/conclusion.  Check how large the
inbox file is and give a warning that it is getting exceedingly large
and that something should be done to purge it.  Evidently, what I
downloaded overflowed my memory capacity and now I can't retrieve any of
what was saved. Even the smallest of editors cannot break the file into
smaller segments.  In essence, I think it is a dumb procedure to pack
everything into one single file.  You know the story about trying to put
10 pounds of____ in a 5 pound bag? Well, to store everything into one
file may be a simple implementation for the programmers,  but after
wasting a full day had a half of my time at my usual rate of $100 per
hour, this programmers short cut cost me approximately $1200 in lost
opportunity.

I hope you'll do something about preventing this from happening again.

I'll keep your references in case I need them again.

Thanks for responding.

Check my closing quote below.


New message Tuesday
-------------------------------
Sorry if this went to the wrong de-bug group.
"Messenger" was not one of the choices.  Another bug!

What is this "Commit" button at the bottom?
Is it supposed to mean "send"?
If yes, why not just say "Send the note."

"Remember values as bookmarkable template?  BOOKMARKABLE???
What dictionary are you using?
I have no idea what the purpose of the button is.
How about using plain old non-jargon English

Template to me means that you are expecting many more complaints.
This is not a good image to present.

Do you have any usability people on your staff or is it all
programmers who talk in jargon?

Finally, in my first visit to the site at the beginning of
this problem, I was totally lost with all of the possible
groups I should visit.  When I didn't know what was wrong,
I felt like Alice in Wonderland when she met the Cheshire
cat in the tree when she asked him which fork in the road to
take.  He asked Alice where she was going and she replied that she
didn't know. The cat replied to take either fork, you'll
end up somewhere.  That is exactly how I felt when I hit
the Netscape site.  I had no idea how to classify my problem
to even begin to guess which path to take.  As a result I
wasted a lot of my time (translation, it cost me money)
because of the poor organization of the site.
There is too much information in too many places!

You need an expert system filter at the beginning to get
people pointed in the right direction.

I'll be amazed if I get a response to this note.

--
Sincerely,

Daniel E. Kolar, Ph.D. CHFP
Certified Human Factors Professional
InfoXfer@Jumpnet.com
Manufacturing Process Analyst

"Thou shalt not waste thy customer's time with an incomplete design."
DEK

Copy my quote and paste it on your cubicle walls.
Then make it part of your operating plan.

Comment 1

18 years ago
infoxfer,  one bug per bug report helps to allow better tracking.
please split this up...  thx.

lets make this one a short and concise definition of the problem
about the ability to handle large messages that exceed diskspace,
and create new bugs for ui usability problems.

can you provide details about the OS you are using, size of virtual memory,
available diskspace before and after the crash to help in building a
reproducable testcase?

Comment 2

18 years ago
infoxfer,  one bug per bug report helps to allow better tracking.
please split this up...  thx.

lets make this one a short and concise definition of the problem
about the ability to handle large messages that exceed diskspace,
and create new bugs for ui usability problems.

can you provide details about the OS you are using, size of virtual memory,
available diskspace before and after the crash to help in building a
reproducable testcase?

Updated

18 years ago
Assignee: phil → jefft

Comment 3

18 years ago
Reassign to jefft. Jeff, please make sure mozilla is respecting
out-of-disk-space conditions. Remember that on NT, that error is reported on the
close(), not on the write().

It's not clear to me whether is bug is referring to Communicator 4.x or to
mozilla, but I'd like to constrain the investigation to mozilla.

Updated

18 years ago
Component: other → Front End
Product: Browser → MailNews

Updated

18 years ago
Component: Front End → Back End

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Reporter)

Comment 4

18 years ago
Bug 16771

I am pleasantly surprised that I got such a quick response after venting
my many frustrations in the original bug report.

My inbox file was about 300KB.  I know, I know, I was about two weeks behind in
my housekeeping and should have cleaned out more files.

I am running Windows 95 on a Dell  Dimension XPS P100c

I've got 32 megs memory

I was running Netscape4.6 when the "illegal operation-shutdown occurred."

The initial error message pointed a finger at Netscape.exe.

That is when I decided to chuck the 4.6 and go for the 4.7 Communicator

One interesting phenomenon was that it crashed first thing in the morning after
I downloaded several files the night before.  On Friday morning, I got into
Netscape momentarily.  I shut it down and it became inaccessible after that.

What really irked me was that the Netscape would not load to let me do anything.
 I moved the large inbox file from the NS directory and put it in a temporary
directory where I tried to access it with my E3 editor.  Not enough memory.

I booted in DOS off a diskette with nothing else running and invoked a Tiny
Editor of only a couple of KB in size. I got a divide by zero fatal message.  I
tried again and I got into the file and started deleting one character at a time
until I erased 900 lines of stuff.  My fingers got tired, so I took a break.  I
will get back to it later to try to squeeze enough room to get a better editor
into memory so I can clean out the remaining files I don't need.

I suspect the divide by zero was the fatal error.  I don't know how that
happened except that I think it is related to exceeding the memory capacity.

Anyhow, I am up and running again.  I now have a different problem in my other C
drive partition.  I formatted it and loaded Windows 95 and for some reason, that
partition cannot recognize the modem and exact same hardware configuration that
the other partition is using right now.   I'm glad that computers are only a
passing fad like CB radios.

Dan Kolar Ph.D. CHFP

Comment 5

18 years ago
marek, you might want to have your engineers to look into this problem for 4.7.

Updated

18 years ago
Whiteboard: [PDT-]

Comment 6

18 years ago
not clear this exists in mozilla
(Reporter)

Comment 7

18 years ago
It got me again this morning.  4.7 was up and running OK for a few days
and then I got hit with this.  Here is the dump.


NETSCAPE caused an invalid page fault in
module <unknown> at 0000:00000392.
Registers:
EAX=00be0484 CS=014f EIP=00000392 EFLGS=00010287
EBX=00bc5830 SS=0157 ESP=00b4f364 EBP=00b4f378
ECX=00bc5830 DS=0157 ESI=00bc5830 FS=0d2f
EDX=00000002 ES=0157 EDI=00000000 GS=0000
Bytes at CS:EIP:
01 91 d0 00 01 91 65 e8 00 f0 d0 00 01 91 20 08
Stack dump:
5f412288 00000000 00bc5830 00bc58f0 00bc5830 006dd196 006e6bb2 00b4f3f8 008028f8
00bc5830 0066b537 0065a609 00da9a10 0066b611 00bc5830 00000000

Updated

18 years ago
Assignee: jefft → marek
Status: ASSIGNED → NEW

Comment 8

18 years ago
Reassign to marek for 4.7 attention...

Updated

18 years ago
QA Contact: leger → hong

Comment 9

18 years ago
Updating QA Contact

Comment 10

18 years ago
Created a 4.x bug in Bugsplat, Scopus ID 369602.  If this is not a problem in
Mozilla, I suggest we RESOLVE this as INVALID and keep the 4.x bug in Scopus
open for tracking.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 11

18 years ago
Per lchiang's request, RESOLVE as INVALID.  Please refer to the scopus bug for
further tracking of this issue.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 12

18 years ago
infoxfer@jumpnet.com - this bug you're reporting is against 4.x.  4.x project is
tracked by an internal bug database to Netscape since that project is not open
source.

For 5.0, we will check this specific case you mention to make sure that it is
handled properly.  Thanks.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.