Closed Bug 1677129 Opened 10 months ago Closed 10 months ago

[Experiment] Sponsored Top Sites move existing pinned Top Sites from their positions

Categories

(Firefox :: Top Sites, defect)

Desktop
All
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox82 --- disabled
firefox83 --- affected
firefox84 --- affected

People

(Reporter: cmuresan, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

[Notes]:

  • Users who use the Pin function would not expect those Top Sites to be moved/changed with anything and would perceive this as an issue as dismissing the Sponsored Top Sites will not revert the changes.
  • Even if the moved Top Sites are not really lost, users won't know this and they would expect to find them only if they change the New Tab page to display more rows of Top Sites.

[Affected versions]:

  • Firefox Beta 83 (Build ID: 20201112153044)
  • Firefox Nightly 84.0a1 (Build ID: 20201108212832)

[Affected Platforms]:

  • Windows
  • macOS
  • Linux

[Prerequisites]:

  • Have Firefox Beta 83 installed and open.
  • To be enrolled in a treatment branch of the “TopSites Launch Phase 3” experiment:
    • Use the Stage environment.
    • browser.partnerlink.useAttributionURL set to true
    • browser.topsites.experiment.ebay-2020-1 set to true
    • browser.search.experiment set to amazon-de-adm
    • browser.topsites.useRemoteSetting set to true

[Steps to reproduce]:

  1. Open the Firefox build from prerequisites using a new profile.
  2. Pin Top Sites on all the available positions.
  3. Enroll in the experiment.
  4. Observe the Top Sites section.

[Expected result]:

  • The Sponsored Top Sites take the first positions available to them without moving already Pinned top sites from those positions.

[Actual result]:

  • Sponsored Top Sites move all Pinned Top Sites to the right.

[Additional Notes]:

  • The issue is also reproducible with the US and GB versions of the experiment.
  • Attached a screen recording of the issue.

This is expected behavior based on how sponsored sites work; they're locked in their specified positions.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.