Closed Bug 1677241 Opened 2 years ago Closed 1 year ago

Weird transparency when viewing videos on Youtube or Twitch

Categories

(Core :: Graphics, defect)

Firefox 82
Unspecified
Linux
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- disabled
firefox92 --- disabled
firefox93 --- fixed

People

(Reporter: persson.einar, Unassigned)

References

(Regression)

Details

(Keywords: correctness, regression)

Attachments

(5 files, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

View videos/streams on Youtube and Twitch.
I tried Chromium and this issue doesnt appear there.
I tried Firefox 83 as well and the issue was still present in a completely new standalone version of Firefox 83 as well.
I also tried Firefox 78 esr and the problem doesn't exist there so it must have appeared recently.
In the screenshot there should be only a grey background but you can see part of my desktop in the video.
link to video: https://youtu.be/9O15vipueLs?t=2187

Actual results:

There are weird graphical issues where sometimes when the screen is certain colors, mainly grey, whatever is behind the window (my desktop background) shows up in the video.

Expected results:

My background shouldn't show up in the video.

Comparing the same youtube video on Firefox 83.0 and Firefox Nightly 85.0a1 with Google Chrome I see a bit difference of transparency when viewing the video on Ubuntu 20.04 x64. I'm not sure of the expected behaviour.

Component: Untriaged → Graphics
Product: Firefox → Core
OS: Unspecified → Linux

Hi persson.einar , thanks for the report. The symptom is weird. Can you attach about:support to this bug?

Flags: needinfo?(persson.einar)

Hmm, I could not reproduce the problem by me:(

:stransky, do you have any ideas about why the problem could happen.

Flags: needinfo?(stransky)

Yes, this may be an incarnation of Bug 1516224. We enable ARGB visual for toplevel window now and clear alpha (Bug 1460959 - https://phabricator.services.mozilla.com/D88558) but we do that for basic compositor only.

Can you attach your about:support?
Thanks.

Flags: needinfo?(stransky)
Attached file about:support
hey again. This is my first time submitting a bug report so please tell me if I'm doing something wrong.
here's the about:support
Attached file about:support
I am experiencing the same on Linux Mint

Sorry, it seems I am unable to edit my post. I wanted to add more description.
I see the high contrast Linux Mint logo in the background of the video. As soon as the video is paused, the transparency disappears.

Better screenshot of the phenomenon.

Attachment #9192908 - Attachment is obsolete: true
See Also: → 1516224

Bug 1686339 - Ghosting in non-fullscreen videos

See Also: → 1686339

Given the about:support info this is a bug in Basic compositor. We already have a workaround for if (https://phabricator.services.mozilla.com/D88558) but I wonder why it's broken now.

I'm unable to reproduce on AMD/radeon and Basic compositor. I wonder if that's NVIDIA only?

Jan, AFAIK you may have NVIDIA card available, can you verify the issue there?
Thanks.

Flags: needinfo?(jan)
Attached video 2021-09-17 01-40-09.mp4

Ubuntu 21.04, KDE X11 with compositor, GTX 1060, Nvidia driver 470

Set quality to 1080p.
mozregression --launch 84 --pref gfx.webrender.force-disabled:true media.av1.enabled:false -a https://www.youtube.com/embed/9O15vipueLs?start=2187

Flags: needinfo?(persson.einar)
Flags: needinfo?(jan)

MOZ_DISABLE_CONTENT_SANDBOX=1 mozregression --good 80 --bad 84 --pref gfx.webrender.force-disabled:true media.av1.enabled:false -a https://www.youtube.com/embed/9O15vipueLs?start=2187

5:50.49 INFO: Last good revision: 5a77c0b857048d46fe4bced46b2234b49dcc84a2 (2020-09-06)
5:50.49 INFO: First bad revision: ca131344e7fcf46f50e09bea63141d2578f18b7b (2020-09-07)
5:50.49 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5a77c0b857048d46fe4bced46b2234b49dcc84a2&tochange=ca131344e7fcf46f50e09bea63141d2578f18b7b

definitely

c500459f5539756b3972d6ab0a0ee7346e328093 stransky — Bug 1663279 [Linux] Update default titlebar configration, r=jhorak

because it can be reproduced with "last good" and mozilla.widget.use-argb-visuals:true

bad: MOZ_DISABLE_CONTENT_SANDBOX=1 mozregression --launch 80 --pref gfx.webrender.force-disabled:true media.av1.enabled:false mozilla.widget.use-argb-visuals:true -a https://www.youtube.com/embed/9O15vipueLs?start=2187
bad: 75
bad: 70
bad: 65
bad: 60
bad: 55
good:50
MOZ_DISABLE_CONTENT_SANDBOX=1 mozregression --good 50 --bad 55 --pref gfx.webrender.force-disabled:true media.av1.enabled:false mozilla.widget.use-argb-visuals:true -a https://www.youtube.com/embed/9O15vipueLs?start=2187

10:04.01 INFO: Last good revision: bdb2387396b4a74dfefb7c983733eed3625e906a (2017-06-01)
10:04.01 INFO: First bad revision: 87c745019518b1d6cd782534f2553721e5735657 (2017-06-02)
10:04.01 INFO: Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bdb2387396b4a74dfefb7c983733eed3625e906a&tochange=87c745019518b1d6cd782534f2553721e5735657

457e6aea4650b4cc8bbc6581342fdc44bc8dbec1 Martin Stransky — Bug 1364355 - Implement UpdateOpaqueRegion() by gdk_window_set_opaque_region(), r=karlt
d04f932669e756a1c673a5f47e68f5596cf6b25f Martin Stransky — Bug 1364355 - Add support for using ARGB windows with OMTC when an X11 compositor is active. r=karlt
411f357ea4853ead25ade894173952516f6ed003 Andrew Comminos — Bug 1364355 - Enable argb visual for GTK window behind hidden preference mozilla.widget.use-argb-visuals, r=karlt


mozregression --find-fix --bad 84 --good 2021-09-16 --pref gfx.webrender.force-disabled:true gfx.webrender.force-legacy-layers:true media.av1.enabled:false -a https://www.youtube.com/embed/9O15vipueLs?start=2187

9:41.90 INFO: First good revision: 16fa627201d13b50df1c1be9ea767eb4d68ff0ba
9:41.90 INFO: Last bad revision: 64c0e09f64462ccbbccc18b80e46492683a5c82e
9:41.90 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=64c0e09f64462ccbbccc18b80e46492683a5c82e&tochange=16fa627201d13b50df1c1be9ea767eb4d68ff0ba

16fa627201d13b50df1c1be9ea767eb4d68ff0ba Andrew Osmond — Bug 1725388 - Remove pref/envvars that can disable WebRender. r=jrmuizel

Not reproducible with Software WebRender:
mozregression --repo autoland --launch 16fa627201d13b50df1c1be9ea767eb4d68ff0ba --pref gfx.webrender.software:true media.av1.enabled:false -a https://www.youtube.com/embed/9O15vipueLs?start=2187

Still not reproducible with Software WebRender.
mozregression --launch 2021-09-16 --pref gfx.webrender.software:true media.av1.enabled:false -a https://www.youtube.com/embed/9O15vipueLs?start=2187

Status: UNCONFIRMED → RESOLVED
Has Regression Range: --- → yes
Has STR: --- → yes
Closed: 1 year ago
Regressed by: 1663279
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.