Closed Bug 1677308 Opened 2 months ago Closed 1 month ago

Ad blockers no longer work with Youtube

Categories

(Firefox :: Untriaged, defect)

Firefox 82
Desktop
Linux
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: chengxiwang.sh, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:82.0) Gecko/20100101 Firefox/82.0

Steps to reproduce:

  • Install any ad blocker (uBlock Origin, Ad Blocker Ultimate, etc.)
  • Start a Youtube video

Actual results:

The video won't start playing immediately unless I click "Skip Ads", although the ad content won't show. See attached.

Expected results:

The video should just start playing immediately.
I tried disable add-ons and refresh Firefox and didn't work.

That is not a browser issue, this is a content blocker issue.

You can try the latest dev build of uBlock Origin[1] and see if this helps or just wait for the next stable release, which I expect to occur this week.

[1] https://github.com/gorhill/uBlock/releases

But I have tried at least 10 different ad blockers and all of them show the same result.

Content blockers failing to block is not a browser issue, not a Firefox issue. If a content blocker fails to block something, report to the maintainers of the content blocker. Sites regularly update themselves to work around content blockers, and as a result filter lists used by content blockers need to be updated, or sometimes the capabilities of content blockers themselves need to be expended. There are cases that can't be solved.

In any case, not a Firefox issue, the issue here should be closed as invalid.

Then why all the aforementioned ad blockers work on other browsers? Plus a freshly installed older version of Firefox with the same ad blockers work perfectly fine. Please do not make a judgement on the validity of the issue if you have no interest in investigating it.(In reply to rhill@raymondhill.net from comment #3)

Content blockers failing to block is not a browser issue, not a Firefox issue. If a content blocker fails to block something, report to the maintainers of the content blocker. Sites regularly update themselves to work around content blockers, and as a result filter lists used by content blockers need to be updated, or sometimes the capabilities of content blockers themselves need to be expended. There are cases that can't be solved.

In any case, not a Firefox issue, the issue here should be closed as invalid.

Attached image ublock.png

Hi Reporter,
Have you tried in latest nightly build? Download the build from : https://www.mozilla.org/en-US/firefox/nightly/all/ .
I tried reproducing on my end, and I'm not facing any issues when playing a youtube video. (no white square, nor skip adds button are shown, video starts playing immediately). I'm using ublock origin.
Best,
Clara

Flags: needinfo?(chengxiwang.sh)

(In reply to Clara Guerrero from comment #5)

Created attachment 9193568 [details]
ublock.png

Hi Reporter,
Have you tried in latest nightly build? Download the build from : https://www.mozilla.org/en-US/firefox/nightly/all/ .
I tried reproducing on my end, and I'm not facing any issues when playing a youtube video. (no white square, nor skip adds button are shown, video starts playing immediately). I'm using ublock origin.
Best,
Clara

Hi Clara,
The issues seems gone after I updated to the latest build since last week. Thanks

Flags: needinfo?(chengxiwang.sh)
OS: Unspecified → Linux
Hardware: Unspecified → Desktop
Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.