Closed Bug 1677325 Opened 7 months ago Closed 5 months ago

Pressing Esc while loading search keyword results leaves address bar in search mode but with full URL

Categories

(Firefox :: Address Bar, defect, P2)

Firefox 84
defect
Points:
3

Tracking

()

RESOLVED FIXED
Iteration:
86.3 - Jan 11 - Jan 24

People

(Reporter: lucas.werkmeister, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

  1. Open a new tab/window (this doesn’t seem to be reproducible on existing tabs)
  2. Type @wikipedia Testign (sic!), or use some other search keyword, and then press Enter
  3. While the page is still loading, quickly press Esc (you’ve realized you made a typo)
  4. Press Ctrl+L or otherwise move to the address bar
  5. Quickly fix the typo by changing “Testign” to “Testing”
  6. Press Enter to submit the fixed search

Actual results:

Firefox opens the URL

https://en.wikipedia.org/wiki/Special:Search?search=https%3A%2F%2Fen.wikipedia.org%2Fwiki%2FSpecial%3ASearch%3Fsearch%3DTesting%26sourceid%3DMozilla-search&sourceid=Mozilla-search&ns0=1

i.e., the English Wikipedia search results for the URL

https://en.wikipedia.org/wiki/Special:Search?search=Testing&sourceid=Mozilla-search

This is because the address bar contents you edited in step 5 are a full search URL, but the address bar was also still in search mode for English Wikipedia (see screenshot).

Expected results:

The address bar should have left search mode immediately, so that editing the search URL did not enter another search for the edited URL. (Or alternatively, the address bar could have stayed in search mode and only showed the search terms instead of the URL, I guess?)

(Note: my user agent says Firefox 83, but I can still reproduce this issue in Nightly 84, version 20201114; I submitted this report from my Developer Edition profile because my Nightly profile isn’t logged into bugzilla.)

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Address Bar

I can reproduce this on Nightly. This is probably another aspect of bug 1675926. We should leave search mode ASAP after the user finishes their search. I'll leave this open for now in case this ends up being a different bug – we should be able to tell once we work on bug 1675926.

Status: UNCONFIRMED → NEW
Points: --- → 3
Ever confirmed: true
See Also: → 1675926
Severity: -- → S3
Priority: -- → P2
Iteration: --- → 86.3 - Jan 11 - Jan 24

Looks like this was fixed by bug 1675926.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.