Closed Bug 1677332 Opened 10 months ago Closed 7 months ago

High GPU usage when color temperature addon used

Categories

(Core :: Graphics, defect)

Firefox 82
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: boxi3m, Assigned: gw, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image Clipboard02.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:82.0) Gecko/20100101 Firefox/82.0

Steps to reproduce:

When add-ons controlling color temperature of the browser are used on websites like YouTube or TradingView.com charts, the GPU usage is goes very high. Those add-ons include
-Firelux
-Color Temperature (Change Lux)

This behavior started about 2 month ago, so in the previous versions of Firefox everything was ok. I think there must be some issue with the newer versions of Firefox.

Please see attached pictures captured when YouTube video is running with Firelux add-on. The GPU is above 51% and sometimes it goes to 75%.

With add-ons disabled the GPU usage is like 5%

Actual results:

GPU usage is very high.

Expected results:

GPU should be normal.

Hi Bo!
I was unable to reproduce this issue on latest Nightly version 85.0a1 (20 and running with Firelux add-on20-11-18) (64-bit) on Windows 10. I've included these add-ons Firelux and Color Temperature (Change Lux) and running with only Firelux add-on enabled. I've attached a file with my evidence.
Could you please try to reproduce it on Nighlty and tell us your input? You can download it from here: https://nightly.mozilla.org/.
Also, I will set a component to have a starting point of this. If this is not the right component please feel free to route this issue to the corresponding team

Component: Untriaged → Graphics
Flags: needinfo?(boxi3m)
Product: Firefox → Core

The Nightly version is the same or maybe even worse. Strange that you can not reproduce it as I have tried on 2 different computers and it's the same issue.
However on Chrome browser everything is fine, when the add-on is enabled the GPU usage is increased but a little, to like 20% while on Firefox 50-70%. That's a big difference.
If you want to try on Chrome you would have to use Color Temperature (Change Lux) extension because Firelux is not available for Chrome. Also make sure it's turned on, so you see the color difference.

Flags: needinfo?(boxi3m)

Hi Bo, thanks for the report. Can you attach about:support to this bug?

Flags: needinfo?(boxi3m)

I confirmed the problem with Firelux addon.

When Direct3D 11 (Advanced Layers) was used, I did not saw the high GPU usage. But when WebRender was used, I saw high GPU usage. It happened both with/without native compositor on my Win10 PC.

Blocks: wr-perf
Blocks: gfx-triage

:gw, can you comment to the bug?

Flags: needinfo?(gwatson)
Severity: -- → S3

Firelux and Color Temperature (Change Lux) are both implemented by adding a solid color div on top with mix-blend-mode: multiply.

mix-blend-mode being applied to the entire content region hits a bad performance path in WR currently.

I am currently working on refactoring the render task graph in bug 1676559. These changes will allow us to then fix this bug by not invalidating and redrawing the entire frame each time.

Assignee: nobody → gwatson
Depends on: 1676559
Flags: needinfo?(gwatson)
No longer blocks: gfx-triage
Blocks: wr-gpu-time
No longer blocks: wr-perf
Depends on: 1682365

With the patch in https://phabricator.services.mozilla.com/D104491 (not landed yet) I confirmed that this drops the GPU usage when this addon is active back to normal.

All the patches for bug #1684781 have landed, I verified that this appears fixed for me. Are you able to verify in a nightly build that it's working fine for you?

Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.