<span> inside <a> doesn't respect "text-decoration:none" style

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
VERIFIED INVALID
16 years ago
13 years ago

People

(Reporter: Chris Lyon, Assigned: dbaron)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Using build 2002091004 on WinXP.

Steps to reproduce:
In an html file, include the following line:
<a href="http://www.mozilla.org/">[underlined]<span style="text-
decoration:none">[no underline]</span></a>

Expected results:
The text in the <span> should not be underlined.

Actual Results:
The text in the <span> is underlined.
(Reporter)

Comment 1

16 years ago
Created attachment 98604 [details]
testcase
That's the correct behavior under CSS1 and CSS2; browsers that suppress the
underline beneath the span are incorrect.  Here's an article that explains the
situation: http://devedge.netscape.com/viewsource/2002/css-underlines/ . 
Resolving INVALID.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
The span isn't underlined. It's the link that is underlined. The span just
happens to be inside the link. Once bug 1777 is checked in, you'll be able to
see this by adding an underline to the span and seeing that you get two separate
underlines.
Status: RESOLVED → VERIFIED

Comment 4

13 years ago
*** Bug 270357 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.