Closed Bug 1677725 Opened 2 years ago Closed 2 years ago

Content prompt text is not vertically centered

Categories

(Toolkit :: Notifications and Alerts, defect)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
85 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox82 --- unaffected
firefox83 --- unaffected
firefox84 + verified
firefox85 + verified

People

(Reporter: pbz, Assigned: ntim)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

The changes in Bug 1583696 broke the vertical alignment of the prompt text. I've attached screenshots.

Tested on Linux and Win10, latest Nightly, clean profile.

Mozregression confirms this: https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=bcabae9c2fed5d2a90657f63161319e9fb08024b&tochange=5ed5e8a6bbfb750504c240ef149149308f50a031

[Tracking Requested - why for this release]:
as-yet unshipped user-visible regression

OS: Unspecified → All
Hardware: Unspecified → Desktop

.tabmodalprompt-topContainer { align-content: center; } might help?

Assignee: nobody → ntim.bugs
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/8968a5912c66
Restore older alignment behaviours on content tab prompts. r=mats
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
Flags: qe-verify+

Comment on attachment 9188329 [details]
Bug 1677725 - Restore older alignment behaviours on content tab prompts.

Beta/Release Uplift Approval Request

  • User impact if declined: Visual regression in JS alert/confirm/prompt UI
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Run alert("Hello world") in the console or use https://javascript.info/alert-prompt-confirm

It would also be nice to test edge cases (e.g long text or long text with lots of spaces in between) as well, to see if nothing regressed from this patch.

  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): small styling change, easy to backout
  • String changes made/needed: No
Attachment #9188329 - Flags: approval-mozilla-beta?

Comment on attachment 9188329 [details]
Bug 1677725 - Restore older alignment behaviours on content tab prompts.

Approved for 84.0b3.

Attachment #9188329 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

I managed to reproduce the issue on an older version of Firefox using Windows 10 x64.
I retested everything using latest Nightly and Firefox 84.0b3 (treeherder) on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.15. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.