Closed Bug 1677781 Opened 11 months ago Closed 11 months ago

Firefox Snap missing media controls in GNOME notification area

Categories

(Release Engineering :: Release Automation: Snap, defect)

defect

Tracking

(firefox85 fixed)

RESOLVED FIXED
Tracking Status
firefox85 --- fixed

People

(Reporter: thedefectiveram, Assigned: olivier)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

Open Firefox Beta (snap), went to YouTube and played a random video. This works fine with regular .deb version of Firefox. I believe the reason being is Firefox snap app does not specify the mpris interface.

Actual results:

Click on the GNOME Notification but there are player controls show.

Expected results:

Media player controls are suppose to show up in the notification shade.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core

Hi Mohan,

Thanks for the report. Does this problem happen in Firefox Nightly as well? I cannot reproduce this issue with Firefox Nightly on my Ubuntu 20.04. Here is what I do:

  1. Open a random youtube video in Firefox Nightly
  2. Check the video info is on the notification area (set via MPRIS)
  3. Pause the video and move to another workspace, then wait for my machine to screen off
  4. After my Ubuntu is logged out, I moved the mouse to wake up my machine and log back
  5. Check the video info on the notification area again.
  6. The result on my Ubuntu: the info of the video stays in the notification area

Would you mind giving a step that can reproduce this issue reliably on your site? I'd like to know what's the difference from the above that can cause this issue.

Flags: needinfo?(thedefectiveram)

Actually this works fine with .deb version on my machine, it is snap version (from snapcraft.io) that is missing the MPRIS. I don't think there is a way to install nightly channel in snap, unless if I am wrong. I believe the only channels available for snap is esr, stable, beta.

Flags: needinfo?(thedefectiveram)

The problem is going to be in the snapcraft.yaml file used to produce the package rather than the Firefox code itself.

A new entry in the slots: section in https://hg.mozilla.org/mozilla-central/file/tip/taskcluster/docker/firefox-snap/firefox.snapcraft.yaml.in would need to be added. Probably something like the following should be sufficient:

slots:
  mpris:
    interface: mpris
    name: firefox

It sounds like the issue here is specific to snapcraft.io, not Firefox itself, so I'm going to close this. If there's something that needs fixing on the Firefox side, feel free to reopen with explanation.

Status: UNCONFIRMED → RESOLVED
Closed: 11 months ago
Resolution: --- → INVALID

@jbauman: note that the snap package published on the Snap Store is maintained by Mozilla (packaging metadata managed in mozilla-central, and packages built on Mozilla infrastructure).

This is not something that can be fixed externally. Looking at other bugs, it is probably better categorised under Release Engineering/Release Automation: Snap.

Thanks for the help, James!

Status: RESOLVED → UNCONFIRMED
Component: Audio/Video: Playback → Release Automation: Snap
Product: Core → Release Engineering
QA Contact: jlorenzo
Resolution: INVALID → ---
Version: Firefox 83 → unspecified
Assignee: nobody → olivier
Blocks: snap
Pushed by jlorenzo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f9d0b2479b0a
add the mpris slot to snapcraft.yaml to enable media controls. r=jlorenzo
Status: UNCONFIRMED → RESOLVED
Closed: 11 months ago11 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.