Closed Bug 1677943 Opened 11 months ago Closed 11 months ago

7.28 - 15.23% youtube-watch (android-hw-g5-7-0-arm7-api-16-shippable) regression on push d9b00e18fe58152b76e79b36d7c5e054dc2f2221 (Fri November 13 2020)

Categories

(Core :: Graphics: WebRender, defect)

Firefox 85
defect

Tracking

()

RESOLVED DUPLICATE of bug 1678570
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- unaffected
firefox84 --- wontfix
firefox85 --- wontfix

People

(Reporter: alexandrui, Unassigned)

References

(Regression)

Details

(Keywords: perf, perf-alert, regression)

Perfherder has detected a browsertime performance regression from push d9b00e18fe58152b76e79b36d7c5e054dc2f2221. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

Ratio Suite Test Platform Options Absolute values (old vs new)
15% youtube-watch android-hw-g5-7-0-arm7-api-16-shippable cold 1,255.90 -> 1,447.24
7% youtube-watch android-hw-g5-7-0-arm7-api-16-shippable cold 1,340.54 -> 1,438.14

Improvements:

Ratio Suite Test Platform Options Absolute values (old vs new)
9% youtube fcp android-hw-p2-8-0-android-aarch64-shippable warm webrender 358.38 -> 326.33
9% youtube-watch loadtime android-hw-g5-7-0-arm7-api-16-shippable warm 1,670.88 -> 1,526.96
9% youtube android-hw-p2-8-0-android-aarch64-shippable warm webrender 350.93 -> 320.91
8% youtube-watch android-hw-g5-7-0-arm7-api-16-shippable warm 947.10 -> 873.76
6% youtube loadtime android-hw-p2-8-0-android-aarch64-shippable warm webrender 492.31 -> 460.62

Details of the alert can be found in the alert summary, including links to graphs and comparisons for each of the affected tests. Please follow our guide to handling regression bugs and let us know your plans within 3 business days, or the offending patch(es) will be backed out in accordance with our regression policy.

For more information on performance sheriffing please see our FAQ.

Flags: needinfo?(aosmond)
Component: Performance → Graphics: WebRender
Product: Testing → Core

Investigating.

Set release status flags based on info from the regressing bug 1676925

== Change summary for alert #27663 (as of Sun, 15 Nov 2020 19:05:47 GMT) ==

Regressions:

Ratio Suite Test Platform Options Absolute values (old vs new)
5% tsvgr_opacity macosx1014-64-shippable-qr e10s stylo webrender 131.38 -> 138.03
5% tsvgr_opacity macosx1014-64-shippable-qr e10s stylo webrender-sw 133.15 -> 139.76

Improvements:

Ratio Suite Test Platform Options Absolute values (old vs new)
4% tscrollx macosx1014-64-shippable-qr e10s stylo webrender 1.13 -> 1.08
4% tscrollx macosx1014-64-shippable-qr e10s stylo webrender-sw 1.09 -> 1.05

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=27663

Same issue as bug 1678570 where I've been doing the investigation.

Status: NEW → RESOLVED
Closed: 11 months ago
Flags: needinfo?(aosmond)
Resolution: --- → DUPLICATE
Duplicate of bug: 1678570
You need to log in before you can comment on or make changes to this bug.