Closed Bug 1678085 Opened 2 months ago Closed 1 month ago

Rendering sometimes corrupt. Mouse move repaints correctly

Categories

(Core :: Graphics, defect)

Firefox 83
defect

Tracking

()

RESOLVED DUPLICATE of bug 1678388

People

(Reporter: elf, Unassigned)

Details

Attachments

(4 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

It is not specifically reproducible. From time to since the upgrade to v83, repainting of a page is corrupted. Moving the mouse over the corruptly rendered area usually corrects the display. Usually, this is seen when selecting a tab that has been active for some time, but not viewed.

This is running on a Macbook Air (mid 2011) with MacOS HIgh Sierra 10.13.6. This is the highest MacOS version supported on the machine.

Actual results:

See the screen shot.

Expected results:

I'm happy to provide before and after if that is what you need. I suspect that the fact that the rendering is obviously corrupt is probably sufficient.

Is this happening on a specific website? Could you please provide the website/websites in order to try to reproduce it?
Thanks.

Flags: needinfo?(elf)

The website from the capture is the Ubiquity UI for their WiFi network controller. I believe I've seen this corruption on bitbucket as well.
I'll continue watching for sites where it occurs. It seems to be common, but it's difficult to reproduce on demans.

You can seen that this isn't specifically about websites. I've added a capture of tabs.

Flags: needinfo?(elf)

Here I was in a Google Meeting in one tab. When I closed the tab, the Firefox tab bar turned to what you see.

And, the same thing happened again when I added the Google Meeting image. I was using this bugzilla in one tab. I posted the image and description about Google Meeting to Bugzilla. Closed the tab, and the tab images were garbled.

Here you can see what Wikipedia is presenting bogus data.

Assigning "Core: Graphics" component.

Component: Untriaged → Graphics
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1678388
You need to log in before you can comment on or make changes to this bug.