Closed Bug 167812 Opened 18 years ago Closed 17 years ago

file:// links to invalid files or links with four slashes fail silently

Categories

(Core :: Networking: File, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 66194

People

(Reporter: whiplash, Assigned: dougt)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

A link to a filename that is not valid in Windows' file naming schema (say,
using a relative link) does nothing at all.  Same goes for a file link with four
slashes (an invalid link.)

Reproducible: Always

Steps to Reproduce:
1. A valid link to an existing file: 
file://c|

2. A valid link to a *nonexistent* file:
file://c|/a_silly_filename_zzyzx_42.foo.baz

3. A valid link to an *invalid* file (note the lack of a drive letter):
file://a_silly_filename_zzyzx_42.foo.baz

4. Another valid link to an invalid file:
file:///a_silly_filename_zzyzx_42.foo.baz

5. An invalid link to an existing file (four slashes):
file:////c|
Actual Results:  
1. The directory of C:\ is displayed.
2. An error message is displayed.
3-5. No response or change.

Expected Results:  
3-4. An error message should be displayed stating either that the file could not
be found, or that the link is invalid.
5. An error message should be displayed stating that the link is invalid.
think this is a duplicate, but I can't find anything recent enough to have
appeared in 1.1

anyway, WFM with 2002111211/trunk/win2k.

reporter (Gordon): can you reproduce this bug with a recent build of mozilla
(for example, 1.2beta)? if so, please comment again with details. if not, please
resolve this bug as WORKSFORME. thanks.
Whiteboard: DUPEME
The second slash is before the hostname which is unimplemented and ignored,
unless it is a drive leter, in which case the drive letter is moved to the next
slash.

If you want to use a UNC, you need 5 slashes.

Please try the format I suggested, and verify if it works correctly.

*** This bug has been marked as a duplicate of 66194 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
#3 is ignored, because we ignore the hostname field (between 2nd & 3rd slash)
#4 should be fixed in bug 128909.
#5 is probably a real problem. I'll check for duplicates, and re-open if this is
not covered somewhere.
You need to log in before you can comment on or make changes to this bug.