Closed Bug 1678154 Opened 1 year ago Closed 1 year ago

Change aarch64 macos builds to be more like the x86_64 ones

Categories

(Firefox Build System :: General, task)

task

Tracking

(firefox84 fixed, firefox85 fixed)

RESOLVED FIXED
85 Branch
Tracking Status
firefox84 --- fixed
firefox85 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

(Blocks 1 open bug)

Details

Attachments

(7 files)

No description provided.
Depends on: 1677023, 1677022, 1677020
Depends on: 1678291

While here, upgrade it to LLVM 11.

Upstream clang supports --target=aarch64-apple-darwin, and that matches
what config.sub canonicalizes to, and thus what the default toolchain
prefix ends up being, so it's better to use aarch64-apple-darwin when
not compiling with Xcode clang.

This also removes some differences between some json files in test
archives.

Blocks: 1678485
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/850591ef50b6
Pack the mac OS SDK as a private artifact. r=firefox-build-system-reviewers,nalexander
https://hg.mozilla.org/integration/autoland/rev/ab764a8bc418
Add aarch64-prefixed binaries to cctools. r=firefox-build-system-reviewers,dmajor
https://hg.mozilla.org/integration/autoland/rev/f03739569a26
Build compiler-rt for aarch64 macos. r=firefox-build-system-reviewers,dmajor
https://hg.mozilla.org/integration/autoland/rev/2f42a2a49d08
Enable aarch64 mac support to llvm-dsymutil. r=firefox-build-system-reviewers,dmajor
https://hg.mozilla.org/integration/autoland/rev/93b9d39d2206
Only set --target=arm64-apple-darwin when building with Xcode clang. r=firefox-build-system-reviewers,dmajor
https://hg.mozilla.org/integration/autoland/rev/8de9f950735e
Create a clang repack including the aarch64 mac compiler-rt. r=firefox-build-system-reviewers,dmajor
https://hg.mozilla.org/integration/autoland/rev/596c75dbdb2c
Change aarch64 macos builds to be more like the x86_64 ones. r=firefox-build-system-reviewers,dmajor

Comment on attachment 9189034 [details]
Bug 1678154 - Change aarch64 macos builds to be more like the x86_64 ones.

Beta/Release Uplift Approval Request

  • User impact if declined: Dependency of bug 1678485
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): This changes the compiler used for Apple Silicon builds from Xcode clang 10 to upstream clang 11. As such, there is a risk of regressions but a) they wouldn't affect other builds, b) we are using clang 11 on other builds already. This also moves the builds to the cloud, which means better capacity in the worker pools and faster builds.
  • String changes made/needed:
Attachment #9189034 - Flags: approval-mozilla-beta?
Attachment #9189028 - Flags: approval-mozilla-beta?
Attachment #9189029 - Flags: approval-mozilla-beta?
Attachment #9189030 - Flags: approval-mozilla-beta?
Attachment #9189031 - Flags: approval-mozilla-beta?
Attachment #9189032 - Flags: approval-mozilla-beta?
Attachment #9189033 - Flags: approval-mozilla-beta?

Comment on attachment 9189028 [details]
Bug 1678154 - Pack the mac OS SDK as a private artifact.

Approved for 84.0b4.

Attachment #9189028 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9189029 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9189030 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9189031 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9189032 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9189033 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9189034 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Beta landing note: the last patch doesn't apply cleanly because a task was added to tascluster/ci/build/macosx-native.yml in bug 1672888. You can solve the conflict by removing the file entirely (because without bug 1672888 there is no task left in the file), and remove the reference to that file in taskcluster/ci/build/kind.yml

You need to log in before you can comment on or make changes to this bug.