Closed Bug 1678155 Opened 4 years ago Closed 4 years ago

Clicking the local one-off heuristic result searches with the default engine

Categories

(Firefox :: Address Bar, defect, P2)

defect
Points:
3

Tracking

()

RESOLVED FIXED
85 Branch
Iteration:
85.2 - Nov 30 - Dec 13
Tracking Status
firefox85 --- fixed

People

(Reporter: bugzilla, Assigned: adw)

References

Details

Attachments

(1 file)

STR

  1. Enter a search term.
  2. Press the up arrow a few times to select the Bookmarks one-off.
  3. Click the heuristic result.

Expected: We confirm bookmarks search mode.
Actual: We send the search term to the default search engine.

Well that's no good. Maybe this just never worked?

Assignee: nobody → adw
Status: NEW → ASSIGNED
Iteration: --- → 85.1 - Nov 16 - Nov 29

Yeah, I just ran mozregression back to bug 1658629 and it looks like clicking the heuristic never worked.

See Also: → 1678765

We currently restyle URL heuristic results when a one-off is selected/search
mode is previewed, but afaict we should restyle all types. In the case of this
bug, the heuristic is a search result. I ended up rewriting most of
browser_oneOffs_heuristicRestyle.js to check various result types (URL, search,
and keyword) and both Alt-arrowing and non-Alt-arrowing down to the one-offs in
case that makes a difference.

This fixes part of bug 1678765, the part where we do the wrong thing when a
restyled keyword result is picked. It doesn't fix the visual part where the
action text is flush against the title text.

This also fixes a small error in UrlbarView._on_SelectedOneOffButtonChanged
where we were using result.payload.title when restyling heuristics, but
result.title is the correct property.

Depends on D97376

Iteration: 85.1 - Nov 16 - Nov 29 → 85.2 - Nov 30 - Dec 13
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e246603a9e27
Restyle all heuristic result types when a one-off is selected/search mode is previewed. r=harry
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: