Contents of Sent folder wiped out

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
16 years ago
10 years ago

People

(Reporter: eric.armstrong, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I had installed Moz 1.1, hoping to find a way to restore the mail folder 
hierarchy. I had 4.77 up to view the hierarchy, and was thinking about 
what harm might come of rearranging the folders in 1.1. (Probably none. 
Probably just index files, but hard to be sure.)

While pondering, a message came in, and I replied to it. I was in 4.77 at
the time.

Error dialog flashed on the screen saying "cannot create folder". Next thing
I know, the sent mail folder is empty, except for the message I just sent.

Now, this bug *could* be confined to 4.77. If so, feel free to jettison this 
report. But it might also exist in the current product, if that code was carried 
forward. 

Basically, this bug suggests that I can't use 4.77 and 7.0 side by side, until I 
decide to definitely make the switch. And that's a problem, because the folder 
hierarchies aren't displaying properly in 7.0 -- which tells me I have to forego 
 the pleasure of 7.0 and stick with 4.77.

(Interestingly, until now, 4.77 has NEVER lost a message -- despite crashing 
repeatedly. So there is something about the 7.0 / 4.77 lock-out strategy which 
is less than perfect.)

Note: The sent mail folder was on my local disk, not the NFS file server.
(Assignee)

Comment 1

16 years ago
Are you somehow sharing profiles between 7.0 and 4.7? Or local mail directories?
I've told some Sun people over and over again that is NOT supported (I think the
folks in China) because they wanted very badly to make it so that they did share
local mail directories by default :-( It's a recipe for disaster, unfortunately.
I'm sorry you lost your Sent mail, and I wish the code/OS prevented this.
(Reporter)

Comment 2

16 years ago
Hey, thanks. I appreciate the caring.

Yeah, pretty much *everything* was shared -- profiles, local mail directories,
the works. The only reason is that Mozilla was displaying all my folders in one 
long list, sorted alphabetically. I had 4.77 up so I could see what the 
arrangement was *supposed* to be, and I was thinking of rearranging them in Moz 
1.1.

It could have been worse. But it was scary. Now, it seems clear that I can't use
them side by side to do the rearranging. And with the folder hierarchy gone, 1.1
isn't very useful.

So that means I'm stuck with 4.x for a while. Hopefully, I'll hear back on the
missing-hierarchy bug (#1678210, and find a solution that will let me switch 
over to 1.1.

Thanks again.
(Assignee)

Comment 3

16 years ago
are you talking about not being able to see your sub-folders because the
directories don't have the names ".sbd"? You can actually fix that by hand if
you want to badly enough :-) by renaming the directories to have .sbd extensions.
(Reporter)

Comment 4

16 years ago
Actually, I was quite glad to hear the response. A known issue involving
ns4.x and mz1.x running simultaneously is not bad. It helps me get a
sense that moz is still solid.

Updated

16 years ago
QA Contact: gayatri → yulian
(Assignee)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: MailNews → Core

Comment 5

11 years ago
david feel free to change if WONTFIX closure isn't appropriate based in the comments about sharing not supported

reporter "have no way to confirm whether or not it works. Feel free to close it"
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.