Closed Bug 1678555 Opened 5 months ago Closed 5 months ago

Switching between contact name formats (first-last, last-first and display) does not update the view

Categories

(Thunderbird :: Address Book, defect)

defect

Tracking

(thunderbird_esr78 fixed, thunderbird84 fixed)

VERIFIED FIXED
85 Branch
Tracking Status
thunderbird_esr78 --- fixed
thunderbird84 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Selecting a different format from the menu sets a preference, but nothing is watching the preference to update the view, so it doesn't change until you select a different address book or reopen the window.

This also remembers the preference value, which should provide a tiny performance improvement.

Target Milestone: --- → 85 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/fee59305845f
Update the address book view when the name format changes. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/c0619f163948
follow-up - Fix linting mistake. rs=linting DONTBUILD

Comment on attachment 9189109 [details]
Bug 1678555 - Update the address book view when the name format changes. r?mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1633620
User impact if declined: menu option in address book window does nothing until reopened
Testing completed (on c-c, etc.): on c-c a few days
Risk to taking this patch (and alternatives if risky): not risky

Attachment #9189109 - Flags: approval-comm-esr78?
Attachment #9189109 - Flags: approval-comm-beta?

Comment on attachment 9189109 [details]
Bug 1678555 - Update the address book view when the name format changes. r?mkmelin

[Triage Comment]
Approved for beta

Attachment #9189109 - Flags: approval-comm-beta? → approval-comm-beta+

Looks good in my test of the 84.0b3 release candidate on Ubuntu 18.04 LTS.

Comment on attachment 9189109 [details]
Bug 1678555 - Update the address book view when the name format changes. r?mkmelin

[Triage Comment]
Approved for esr78

Attachment #9189109 - Flags: approval-comm-esr78? → approval-comm-esr78+

Verified in testing of the Thunderbird 78.6.0 release candidate on Windows 10.

Status: RESOLVED → VERIFIED
Keywords: regression
You need to log in before you can comment on or make changes to this bug.