crash when attempting to download iCal [@ nsExternalAppHandler::SetUpTempFile]

VERIFIED FIXED

Status

Camino Graveyard
Downloading
--
critical
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Thomas F. O'Connell, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({crash})

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020909
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020909

i was hoping to download brand new software (iCal) with my brand new software
(Chimera 0.5.0), but my attempt failed in crash.

Reproducible: Always

Steps to Reproduce:
1. launch Chimera Navigator.
2. visit http://www.apple.com/ical/download/index.html
3. fill out the form.
4. click Download iCal
Actual Results:  
at this point, Chimera crashes. 

Expected Results:  
launched the downloader and saved the file.

i'm not sure if this is actually a problem with the downloader or with something
arcane in the way Apple has constructed the downloading page/form.

Comment 1

16 years ago
I can't reproduce this. 

After I click download I am prompting to save the file, then after choosing a
location the download proceeds normally. I'm currently running on an iBook
700MHz, 128 MB, running 10.2.

(Reporter)

Comment 2

16 years ago
more system specs:

i'm running Jaguar on a PowerBook G3 Firewire.

i tried this several times and got a crash. i had been using Chimera comfortably
for most of the day and had visited a variety of sites. maybe i can try to get a
trace.
(Assignee)

Comment 3

16 years ago
a stack trace is worth a thousand words, given that i did this yesterday myself
and it worked (0.5 build, 10.2), albeit it was my desktop, not my pismo powerbook.
(Reporter)

Comment 4

16 years ago
ok, can you give me a quick starter guide to doing a stack trace on Desktop
apps? i've done them before on *NIX command-line apps. do i just run Chimera
from Terminal or something?

Comment 5

16 years ago
Thomas, see [http://www.mozilla.org/mailnews/osxinfo.html], particularly
"Enabling Crash Reporter in OS X *10.1*."
Keywords: crash, stackwanted

Comment 6

16 years ago
I wasn't able to reproduce either using the 2002-09-11-05 build under 10.2
(6c115). Tested on Power Mac G4 Dual 800.
(Reporter)

Comment 7

16 years ago
Created attachment 99008 [details]
stack trace of crash

i still get the crash. same steps to reproduce. trace attached.

Comment 8

16 years ago
WorksForMe using Chimera/2002090913 on 10.1.5.
Keywords: stackwanted
Summary: crash when attempting to download iCal → crash when attempting to download iCal [@ nsExternalAppHandler::SetUpTempFile]
(Reporter)

Comment 9

16 years ago
so is it possible that it's an architecture issue? has anyone else tried it on a
PowerBook G3, yet?

Comment 10

16 years ago
This happens when IC has no setting for your default download folder (which can
happen for new 10.2 accounts). It was fixed yesterday.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 11

16 years ago
Reporter,

Please check with the latest build.

Chris
(Reporter)

Comment 12

16 years ago
well, unfortunately, i've since set my Download location, and i don't know of an
easy way to unset it.

Comment 13

16 years ago
verified
Status: RESOLVED → VERIFIED

Comment 14

16 years ago
*** Bug 170409 has been marked as a duplicate of this bug. ***
Crash Signature: [@ nsExternalAppHandler::SetUpTempFile]
You need to log in before you can comment on or make changes to this bug.