Closed Bug 1678974 Opened 2 years ago Closed 2 years ago

"Mark Messages as Read by Date" broken - Uncaught Exception { name: "NS_ERROR_FAILURE", message: "Failure arg 0 [nsIMsgFolder.markMessagesRead]"... }

Categories

(Thunderbird :: Folder and Message Lists, defect)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1648014

People

(Reporter: hsi, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, regressionwindow-wanted, ux-efficiency)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

  1. Press "c" to open "Mark Messages as Read by Date" dialog
  2. Enter a "Mark messages as read from" (or leave "from" it empty) and "To" date
  3. Press OK

Actual results:

No message in the given time frame gets marked as read

Expected results:

Messages in the given time frame should be marked as read

Danke!

Confirming exactly as described, tested on 78.5.0 (64-bit).

Console Error:


Uncaught
Exception { name: "NS_ERROR_FAILURE", message: "Failure arg 0 [nsIMsgFolder.markMessagesRead]", result: 2147500037, filename: "chrome://messenger/content/markByDate.js", lineNumber: 121, columnNumber: 0, data: null, stack: "markInDatabase@chrome://messenger/content/markByDate.js:121:19\nonAccept@chrome://messenger/content/markByDate.js:63:17\n_fireButtonEvent@chrome://global/content/elements/dialog.js:487:19\n_doButtonCommand@chrome://global/content/elements/dialog.js:466:29\n_handleButtonCommand@chrome://global/content/elements/dialog.js:460:19\nMsgMarkReadByDate@chrome://messenger/content/mailWindowOverlay.js:2466:10\ndoCommand@chrome://messenger/content/mail3PaneWindowCommands.js:957:9\ndoCommand@chrome://messenger/content/mailTabs.js:844:23\ndoCommand@chrome://messenger/content/tabmail.js:577:27\ngoDoCommand@chrome://global/content/globalOverlay.js:101:18\noncommand@chrome://messenger/content/messenger.xhtml:1:12\n", location: XPCWrappedNative_NoHelper }
markByDate.js:121

Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: "Mark Messages as Read by Date" broken → "Mark Messages as Read by Date" broken - Uncaught Exception { name: "NS_ERROR_FAILURE", message: "Failure arg 0 [nsIMsgFolder.markMessagesRead]"... }

Regression, still works in 68.12.1 (64-bit)

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1648014
You need to log in before you can comment on or make changes to this bug.