Closed Bug 1678989 Opened 2 months ago Closed 1 month ago

360 Videos on Youtube are not displayed correctly anymore. The colors are wrong. It started with the update yesterday. I'm on OS Catalina 10.15.7, my firefox version: 83.0.

Categories

(Core :: Graphics, defect)

Firefox 83
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox83 --- affected
firefox84 --- affected
firefox85 --- unaffected

People

(Reporter: efende, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

playing yt 360 videos

Actual results:

after the update colours of the 360 content are not displayed correctly anymore

Hi Lukas can you provide me a YouTube link for me to text to reproduce this bug and also can you provide me your about:support information to help me find the bug.

Flags: needinfo?(efende)

Hey Amdrew:
This is one of the distorted videos: https://youtu.be/cYqF84RgLME
But it seems that all 360 videos (you can choose your own perspective while watching) have the same colour problem.
On other browsers as safari the videos still work fine.
I don't actually don't know what this means: about:support information.
gritz from vienna.
lukas

Flags: needinfo?(efende)

Hi Lukas,

I was able to reproduce the issue reported on iMac OSX 10.15.3 using Firefox Release version 83.0 and on Firefox Beta 84.0b7. However, I haven't been able to reproduce it on Firefox Nightly 85.0a1 (2020-12-02).

I wasn't able to reproduce this on a Windows 10 machine.

Can you please download Firefox Nightly and test if you can see the correct colors as well? You can download it from here: https://nightly.mozilla.org/

Since the issue seems to have been solved on the latest version of Firefox Nightly, it means that it will be fixed when Release version reaches 85. But just in case please let us know the results you get so we can continue investigating.

Thanks in advance,
Virginia

Status: UNCONFIRMED → NEW
Component: Untriaged → Audio/Video
Ever confirmed: true
Flags: needinfo?(efende)
Product: Firefox → Core

Hi Virigina,

I tried Firefox Nightly and yes, it worked out fine. No displaying problems anymore.
I hope the new version comes soon, because this bug looks quite bad and I'm just launching a new 360 performance project.
Anyhow, the bug seems to appear only with the AMD Radeon Pro 5500M and/or the i9. I asked a friend with the same mac but cheaper graphic card and i7 to reproduce the bug - he couldn't, displaying worked out perfectly fine.

Thank you so much,
Lukas

Flags: needinfo?(efende)

Youtube uses WebGL to draw 360 video contents. Moving component to Graphics.

Component: Audio/Video → Graphics

Closing based on comment 4.

Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → WORKSFORME

Hey guys,
still waiting for a new firefox version where this bug doesn't exist anymore.
Yes, with the firefox nightly it works out fine. But nobody uses this version.. I hope that not to many people are using firefox with a mac book pro 16, i9, AMD Radeon Pro 5500M and trying to watch 360-Content on youtube. Because it looks quite poor..

Anyways, thanks for your responses and ideas.
Best wishes from Vienna,
Lukas

You need to log in before you can comment on or make changes to this bug.