Proxy settings are not gleaned from the active network interface

RESOLVED FIXED

Status

Camino Graveyard
General
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Jim McCarty, Assigned: saari (gone))

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020909
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20020909

With a network location that has two (or more) interfaces, the proxy settings
should be gleaned from the active interface. In Chimera, the proxy settings are
gleaned from the primary interface only.

Reproducible: Always

Steps to Reproduce:
1. Configure a network location with two interfaces (say AirPort and Built-in
Ethernet). Set one to use a proxy server and the other for no proxy server.
2. Start Chimera on a network that uses the primary interface (the first
interface in the pop-up) and browse the internet. Close Chimera.
3. Switch to a network that uses the secondary interface (and different proxy
settings) and start Chimera.
4. Browse the internet.

Actual Results:  
Chimera times out attempting to contact the requested URL - either because it's
trying directly when it should be using a proxt server, or it's searching for a
proxy server when it should be connecting directly

Expected Results:  
Chimera should read the proxy settings from the currently active interface. If
the active interface should change while Chimera is running, Chimera should
update/reload its proxy settings (see bug #167900) from the new active interface.
Moving to General, as this is more of a Networking problem, I believe.
Assignee: sfraser → saari
Status: UNCONFIRMED → NEW
Component: OS Integration → General
Depends on: 167900
Ever confirmed: true
QA Contact: petersen → winnie

Comment 2

15 years ago
So this is why my proxy settings are ignored on my ibook (airport has proxy
setting, ethernet does not).
I would think the severity on this should be higher, but that's probably just
because it affects me.

Comment 3

15 years ago
This is fixed now.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.